turn key and nothing happens,no click [Archive] - GrandAmGT.com Forum

PDA

View Full Version : turn key and nothing happens,no click


GranGT05
10-01-2009, 07:28 PM
I went to leave work the other day and I turned the key and everything lit up but nothing happened.No click or anything.The next morning it started right up and has been fine for the past few days???. I hooked up (GM tech 2)scan tool to it and no codes.I have a 05 GAGT with 87k.The security light DID NOT come on and flash when this happened.I am also trying to find a cure for the dimming headlights when I hit the brakes.Not sure if there is a cure for this from what I have read.

GrandAmMe
10-01-2009, 07:30 PM
It sounds like either a dead battery or alternator......Most likely the alternator cause of the dimming headlights. My car did the exact same thing when i turned they key nothing! but the positive cable was loose and as soon as i tightened it, it came back to life!

PhantomLover007
10-01-2009, 07:45 PM
Check your fuses first. You may have a partially blown fuse.

IIRC, you'll know it's the alternator if you disconnect the negative cable from the battery and the car dies.

Correct me if I'm wrong ya'll

ltpats
10-01-2009, 07:54 PM
IIRC, you'll know it's the alternator if you disconnect the negative cable from the battery and the car dies.

Correct me if I'm wrong ya'll
That used to be true, not a good idea anymore, can cause the alternator to spike damaging the alternator and or other electronic components.

Also a fuse can't be partially blown, it's either good or bad.

lone_wolf025
10-01-2009, 07:56 PM
IIRC, you'll know it's the alternator if you disconnect the negative cable from the battery and the car dies.

Correct me if I'm wrong ya'll

Car would die anyways if you did that.

The way to check the alt is to electrically load up the engine by running lots of high draw items and run an alt check. Since the car starts on occasion but sometimes doesn't my money is on a bad battery. Probably a bad cell or two.

Had this happen to me once. Everything was dead and voltage was down in single digits. So I hooked up the charger and an hour later its back up to 12 volts and all is running fine. Turns out it was a bad cell on the battery.

I'd check both though. Wouldn't be too hard.

ltpats
10-01-2009, 07:57 PM
It sounds like either a dead battery or alternator......Most likely the alternator cause of the dimming headlights. My car did the exact same thing when i turned they key nothing! but the positive cable was loose and as soon as i tightened it, it came back to life!

If the battery is dead it's dead, while they can somewhat rejuvinate themselves after sitting a while it sounds due to him saying that it started fine the next day I'd be more apt to believe a connection somewhere.

lone_wolf025
10-01-2009, 08:23 PM
If the battery is dead it's dead, while they can somewhat rejuvinate themselves after sitting a while it sounds due to him saying that it started fine the next day I'd be more apt to believe a connection somewhere.

If its got a bad cell it can. My batt went from -so low not even the dash lights turned on- to -starts right up no problem-. But in the majority of situations you're right.

GranGT05
10-03-2009, 08:44 AM
As far as the starting problem goes My alternator is charging fine and the battery is good as the next morning I went and the car fired right up.I am thinking maybe the starter selonoid acted up or a possible loose connection at the starter as the connections to the battery are tight and clean.It has been about 4 days and has not done this again????.I have a service contract so I may just go ahead and have the starter replaced.

skifreak122
10-03-2009, 09:07 AM
Make sure to clean your battery connections extremely well. Corrosion will also get into the cables under the protective covers. So checking out the cables and cleaning/tightening the connections would be the first place I'd check.