Trac off, abs, and i think its service vehicle lights come on [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Trac off, abs, and i think its service vehicle lights come on


icecats87
10-07-2009, 04:34 PM
Every time i really turn my tires pretty fast, or like go in reverse backing out of a spot and going in drive then go forward those 3 lights come on. what could cause this?

i_ammetal
10-07-2009, 04:44 PM
Having the same problem.... ive been told its the wheel speed sensor on one of the front hubs.... i guess its also a somewhat common problem

I got a quote from a repair shop in Aurora for $383 to replace the whole entire hub assy. an hour ago... still waiting to get word on if this is an easy fix or better off going to a repair shop

i_ammetal
10-07-2009, 04:52 PM
And try searching more often there are quite a few threads on this topic!

zukiracer19
10-07-2009, 06:43 PM
usually this happens to me when i my tires spin to fast usually in burnout pit or if i mash on it my car will eventually shut off and those lights will come on.

skifreak122
10-07-2009, 08:30 PM
Search and read. There is tons of info on these forums about these cars. It's not a hard job if you have the correct tools and are familiar with cars.

This should cover just about any questions you have on the issue:
http://www.grandamgt.com/forum/showthread.php?t=42959&highlight=wheel+speed+sensor


These will show you how to replace if necessary:
http://www.grandamgt.com/forum/showpost.php?p=1063788&postcount=75

http://www.gaownersclub.com/forum/showthread.php?t=41086


It is best to check the condition of the wiring/connection first. Pull it apart, clean it, check for breaks in the wires.