Car cranks but won't start, running outta ideas, please help! [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Car cranks but won't start, running outta ideas, please help!


meccamann
10-22-2009, 02:16 PM
Hey guys, my car won't start. I've read through dozens of threads relating to what may be my car's problem and have tried most of the solutions suggested. But, I'm still gonna ask for your guys' help anyway, hopefully somebody can help me out!

So I was driving home from work last night on the highway, going about 70 mph. Car was working just fine. No hesitations, no stalling, no dimming lights, nothing. As I start getting onto the exit ramp, which is not steep whatsoever, I feel the car lose power, felt like somebody switched it from drive to neutral. I press the gas, no power, than I slowly feel the damn steering wheel locking up, and before I know it I'm sitting on the side of the road wondering why my car sucks balls.


Things that may need to be known to assess the problem:

-Battery is fairly new (bought it sometime last year)
-Fuel filter was replaced last summer
-Fuel injectors were cleaned out last summer
-Spark plugs and wires were replaced last summer
-O2 sensor was replaced last summer
-Have been having trouble with the idiot Passlock feature (have had to reset it several times in the past year)

So after my car decided it hated me, I tried starting it several times. All my electrical components were working just fine: radio, headlights, interior lights, diagnostics, etc. And I could even here the quiet humming of the fuel pump, and the car was cranking like it wanted to start, but it didn't.

So I have my dad help me tow it home and the next morning (today) I try starting it and again, all crank no start. I tried resetting the Passlock like 2-3 times. Nothing. I don't really think it's the fuel filter or pump. I haven't yet check any of the fuses, but will later today when I get off work. And other than that I can't really think of what the hell it could be.

So if ANYBODY has any input or ideas as to what the hell's wrong with my car I'd greatly appreciate it. Thanks guys! Oh, and any other info that might help just ask.

zukiracer19
10-22-2009, 02:23 PM
http://www.samarins.com/diagnose/index.html

razobladez
10-23-2009, 12:56 PM
Check to see if there is power to ur fuel pump.

KmGADfw
10-23-2009, 01:26 PM
What engine, tranny and mileage will be helpful.

Have you tried to crank while holding the gas pedal down yet?

Lab Rat
10-23-2009, 01:52 PM
A clogged cat stopped me on the highway. Took me 2 days to figure out. Might want to look into that. Good luck with the fix.

meccamann
10-23-2009, 03:03 PM
There's definitely power going to the fuel pump. I can hear it humming when the key is in the acc or on position, so I don't think it's that.

It isn't a clogged catalytic cuz that was replaced last summer as well.

Oh, and to answer ur question KmGADfw, it's a 3.4L V6 automatic with 98,826 miles and yes, I've also tried holding down the gas pedal.

And if it helps, when I keep the key in the "on" position the battery, oil, security and service engine soon stay solidly lit, no flashing of the security, which makes me think it's not the Passlock feature messing up.

I'll be checking the fuses and relays tomorrow and running a diagnostics check to see if I can pull some codes up, along with replacing the fuel filter in case this is all just an easy fix.

KmGADfw
10-23-2009, 04:58 PM
This does not sounds like fuel related. Have you tried to see if you get any sparks from the spark plug while cranking - I am suspecting that the power distribution to the spark plug might be at fault - can't be the coil pack, since you have 3 separate ones and they can't go out at the same time.

If this failed, the next thing might be the timing chain / tensioner - I know it normally would not fail at this mileage, but there is possibility.

aiixon
10-24-2009, 02:41 AM
fuel pump relay.

Tonyyank
10-24-2009, 10:05 AM
spray either in the MAF while cranking.......

2000 GT Coupe
10-24-2009, 11:23 AM
if the security light is on past the few seconds to test the bulb then it is affecting the start.

350rs
10-24-2009, 12:43 PM
how are you resetting the passlock? That same thing happened to me several times and i had to reset it. I think i did it something to the effect of; lock, unlock, unlock, turn key to on for something like 10 or 12 mins. The light would go off. I then would turn the key off and start right up. In the end that ignition cylinder had to be replaced. about a $500 bill at the dealer. IDK if its something that can be done at home or not honestly.

meccamann
10-24-2009, 02:22 PM
Ok so I replaced the fuel filter this morning, it was dirty as hell. Tried starting the car, absolutely nothing, not even a crank. I saw the security light blinking so I did the standard procedure that all of us grand am owners just loooove doing. After about 12 mins the security stopped blinking. I tried starting it again and it cranked, but no start, damnit...... :/

I pulled out the fuel line that connects to the fuel injector pressure regulator (see autozone's website for a picture of it if u don't know what I'm referring to) to see if there was any fuel coming out of the line like there should be, but, surprise surprise, there was none. I also ran the OBD II diagnostics test on it and no codes pulled up, what the hell?? Lol.

So at this point I've narrowed it down to a fuel delivery problem. U guys think it could be a ****ty alternator by any weird chance??

Tonyyank
10-24-2009, 02:32 PM
try shooting brake cleaner into the MAF while cranking!!!!

alocaurd
10-24-2009, 03:35 PM
seeing how it wont start, im assuming you havent moved the car? seems obvious, but any fuel on the ground when you were changing your filter?

aiixon
10-24-2009, 04:21 PM
I'm telling you it's the fuel pump relay. These things go out a lot on these cars.

meccamann
10-24-2009, 07:36 PM
Update: I checked to see if the fuel pump relay was shot and it wasn't that. I checked it by swapping it with the relay for the horn and still no dice.

I sprayed starter fluid into the MAF while cranking the car and still nothing.

I even took the new fuel filter out to see if there was at least fuel going into it and was a little surprise to see that the the filter came out just about as dry as it was going in.

So now I'm in the process of removing the gas tank so I can check the fuel pump, god what a pain the ass...... :/

GrandAmMe
10-24-2009, 07:38 PM
Hmm must be a pinched wire or electrical messup...

meccamann
10-24-2009, 10:08 PM
Ok quick update: I just finished dropping the fuel tank and removing the fuel pump. I went to autozone and came out about 240.00 poorer. I would've bought it online for about 100.00 cheaper but I'd rather not wait a week or so for processing and shipping.

I'm really hoping this is the fix I'm looking for. Quick question fellas, if this problem were somehow electrically related (fuse, relay, computer problem, etc.) the OBD II sensor I tried earlier would've for sure pulled up SOME kinda code no?

2000 GT Coupe
10-24-2009, 10:13 PM
Not if it is theftlock related, unless the scanner reads more then just pcm.

AaronGTR
10-25-2009, 08:56 AM
I pulled out the fuel line that connects to the fuel injector pressure regulator (see autozone's website for a picture of it if u don't know what I'm referring to) to see if there was any fuel coming out of the line like there should be, but, surprise surprise, there was none. I also ran the OBD II diagnostics test on it and no codes pulled up, what the hell??


Just FYI, the line that connects to the pressure regulator is the return line, not the supply line. ;) It isn't supposed to have any pressure. The fuel goes into the rails directly from the line on the back of the engine, the regulator on the end of the front rail keeps the pressure up inside the rails, then lets excess fuel go out the bottom into the return line. If you want to check fuel pressure, turn your key on and take off the black plastic cap on the left side of the rear fuel rail (by the alternator and power steering pump). That is the pressure test port. Hold a rag around it and push in on the center pin with a screw driver for a second. Should have fuel spraying out (be careful not to get it in your eyes of course).


This doesn't sound like a fuel problem to me. It sounds more like an ignition problem. Maybe a bad ignition control module or a bad cam or crank sensor. Weird that there are no codes though. It could also be a problem with the passlock security. That really isn't that common on these cars, but it does happen. If you have trouble with the security light more than once, that is definitely not normal and means there is an underlying problem with the system that needs to be taken care of. Don't just keep doing the security relearn and driving it around 'cause you'll keep having trouble with it.


edit: for the question on codes, if there is something wrong electrically with the car it will often set a code in the computer... but not always. It depends on what system and sensors it's related to and what kind of tests the computer runs on that system. You can have electrical problems and not get a code.

meccamann
10-25-2009, 01:45 PM
So I just finished replacing the fuel pump. I turned the car on, it cranked, and then it started!! Boo-yah!!! Haha. About damn time I was able to find the problem. I kinda had a feeling this was it all along I was just hoping it wasn't cuz I didn't wanna go through the hassle of removing the fuel tank and whatnot.

On another note, thanks for the clarification on where to test for fuel pressure AaronGTR, I had no clue I wasn't checking it right, good to know for next time tho!

AaronGTR
10-25-2009, 06:59 PM
No problem. Glad to hear you got it running. :)

carlos m.
07-22-2010, 12:05 AM
Using a horn relay instead of the specific fuel pump relay--will not start the engine. Get a new fuel pump relay and it should start right up.