Grand Am hard to start [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Grand Am hard to start


realestdriver
11-26-2009, 05:23 PM
My GA is taking a long time to startup after I let it sit for a while(not just mornings). Once I do get the car started and drive it for a while, then kill it it'll start right back up. The only way to get it to start on the first try is to prime the fuel pump a few times at the ignition switch. Also it is idling rough at times, if that might be related. I'm thinking fuel system as of now, any suggestions. I'd appreciate it.

350rs
11-26-2009, 09:54 PM
hows it running?

at first i would think fuel filter is getting clogged, but also maybe the pump is begging to fail.

Have you done any kind of tuneup lately?

PhantomLover007
11-27-2009, 10:46 AM
Battery connections clean?

Pauljp
11-27-2009, 01:04 PM
Maybe the fuel is bad. Did you just fill up when this happened?
Dirty MAF or EGR? Try cleaning them. Low cost, easy and doesn't hurt.

realestdriver
11-27-2009, 05:34 PM
I've noticed a rough idle ever since I put on my throttle body, but I don't think thats a problem. Replaced the battery with an optima I had around. I remember cleaning my maf when it first started that rough idle. The car has been tuned up recently and my fuel filter was replaced about six months ago. 92 octance in the tank. During daily driving it performs about normal.

It kinda seems that not enough fuel pressure was held up at the fuel rail when its being an ass to start. Fuel pressure regulator?

realestdriver
12-03-2009, 03:27 PM
FIXED***

Replaced fuel pump on tuesday, car has been running great ever since. Very quick start and smoother idle. Feels like a definitely gained some power back, particularly in the 3-4k range. Time for another 1/4mile!