Fuel Pump going? [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Fuel Pump going?


Quaf069
12-01-2009, 06:55 PM
Hello all,

i have been having issues with my 2000 Grandam GT (124k miles) the last week. I would be driving on the highway....and suddenly feel a "jerk" in the car...or a hesitation...then the car would shut off. I would put my foot on the gas pedal...but nothing happens....(lights/radio remain on while this happens). i have to pull the car off to the side of the road.

I try to restart it...it turns over for a bit but wont restart. After 3 minutes...I will try again and it will start and I can drive again.


The above sequence happend 3 times in a row today to work. On my way home, I took local roads (slower speeds) and didnt have any issues.


From the symptoms, I'm guessing it sounds like my fuel pump is going. I will probably take it to a mechanic. Any ideas what this will $$, so I know what to expect?

Thanks for any input you may have.

Quaf

RPO3
12-01-2009, 09:45 PM
Sound like it bro...

Metclub
12-02-2009, 01:19 AM
When you try to start your car do you hear the fuel pump turning on? If not that is your problem. Its actually a pretty easy fix on your own if you have the tools and make sure the gas tank is empty it can be pretty heavy if your doing it on your own!

butcherbutch
12-30-2009, 10:18 AM
I have a similar issue but it doesn't stall. Did yours start by just doing that hestitation at first then get worse? I feel it most when I am going between 40-70+, not at the lower speeds. I feel it less when I use cruise control.

Is that how yours started?

Thanks,
Butch

ryanbgb22
12-30-2009, 10:52 AM
Most likely a fuel pump or a fuel filter. To confirm this, right after the car stalls next time, and it just cranks without starting, pull the vacuum line out of the air intake right before the throttle body. Spray injector cleaner/carb cleaner/starting fluid in there. If the car starts, you know it's fuel related.

timberwoof
09-30-2010, 10:48 PM
Just curious as to how this turned out. Mine just did this today. I thought i may be the fuel filter, so I replaced it and it still did it. I'm thinking the fuel pump is overheating and shutting off. Never stopped to check if it was turning on after it stalled. OP what was your conclusion. Thanks.

[ChaosweaveR]
09-30-2010, 10:51 PM
That sounds like a fuel pump to me. At least yours wasn't like mine, and just dies out of nowhere, and completely dies out.

Better find a good mechanic who's good with labor, or do this yourself, the tank's gotta be dropped to get to the fuel pump.

timberwoof
10-01-2010, 07:15 AM
I can do this myself, only problem is the price of the pump.

remiljr
10-01-2010, 03:54 PM
I can do this myself, only problem is the price of the pump.

yea..i priced it at 260$ check the relay and or replace it first. 15$ vs 260$

zukiracer19
10-01-2010, 04:24 PM
mine does this too, but my security light sometimes comes on, sometimes it doesnt, half time it doesnt prime, im willing to bet its your relay, i have yet to get underneath mine to put the racetronix pump in because no point, unless i decide to blow my 3400 for ****s and gigs and throw my spare motor in and make it stock again.