2000 Grand Am Gt coolant problem... [Archive] - GrandAmGT.com Forum

PDA

View Full Version : 2000 Grand Am Gt coolant problem...


louisville
12-20-2009, 07:24 PM
Last night on my way home from a christmas party, my temp gauge flatlined a red warning light. I stopped at a gas station , and turned her off. Steam was rolling out from under the hood . I heard a whistling sound and noticed it was coming from (around) my thermostat area. The store i was at did not sell dexcool , so i filled her up with water , LIVE 4 MILES AWAY. Drove her home for the night .

Today i replaced the thermostat and filled my coolant tank w/ dex-cool 50/50.
(Bled the system) . Cleaned up a couple of puddles of antifreeze sitting right under the thermostat housing .
So i went for a test drive and it still wasent right . Temp gauge DID NOT red line, but DID get a little high .
Car did have the whistling sound again , with steam again like the night before . NEW puddles of coolant in the same place
as before .

Im wondering if this sound like the waterpump or not ?
even though the water pump is on the other side ?
Coolent temp sensor ?

ANY toughts on this would be greatly appreciated .

XtremeGaGt00
12-20-2009, 10:09 PM
pics?..location of the puddles?..id say fill the system and pressure test it if you cant locate the prob

meanse99
12-20-2009, 10:30 PM
pics?..location of the puddles?..id say fill the system and pressure test it if you cant locate the prob

yeah i agreed pressure test it when its cold and if its ok start it and let it run on the pressure

louisville
12-21-2009, 06:12 AM
does the local parts stores rent pressure testing equipment?