service vehicle soon light? [Archive] - GrandAmGT.com Forum

PDA

View Full Version : service vehicle soon light?


blondiez24gt
12-22-2009, 08:31 PM
My car popped the service vehicle soon light up today. I stopped at autozone, and had it scanned. They said nothing popped up. They tried it again, and said there were no problems. Why would this light be on?

onesexyga
12-22-2009, 08:38 PM
AFAIK autozone only reads check engine lights, not SVS. Could be a lot of things. Any other symptoms the car is showing would be helpful. Otherwise, get it checked out.

blondiez24gt
12-22-2009, 08:47 PM
I don't know of any other problems, or symptoms. I was just driving down the road today, and the svs light popped on.

skifreak122
12-22-2009, 09:53 PM
Check your headlights. One of the bulbs may be burnt out.

GrandAmMe
12-22-2009, 09:56 PM
check your headlights. One of the bulbs may be burnt out.

x2

350rs
12-22-2009, 10:18 PM
agreed. SVS is usually stupid things. lights and things of the sort. Check them out.

blario
12-23-2009, 12:32 AM
My DRL relay had failed once, causing a SVS light. So if it's not a bulb out, check you DRL and auto headlight relays.

blondiez24gt
12-23-2009, 02:45 AM
My headlights worked fine, but I did see a slight problem. I don't know if this would throw the light or not. When I was looking at the headlights the passenger one was all out of whack. I took the headlight out, and the ring that you twist to hold the bulb in had the fins broke off of it. The bulb was sitting back in that little black metal cage that encircles the bulb when fully installed in the lens. I'm guessing that is what blocks off some of the light so it knows when to turn on the headlights automatically. Being as the bulb was sitting back 1/2" to 3/4" further than it was suppose to could that throw the light?

IanGT99
12-23-2009, 10:26 AM
My headlights worked fine, but I did see a slight problem. I don't know if this would throw the light or not. When I was looking at the headlights the passenger one was all out of whack. I took the headlight out, and the ring that you twist to hold the bulb in had the fins broke off of it. The bulb was sitting back in that little black metal cage that encircles the bulb when fully installed in the lens. I'm guessing that is what blocks off some of the light so it knows when to turn on the headlights automatically. Being as the bulb was sitting back 1/2" to 3/4" further than it was suppose to could that throw the light?

Common problem. I replaced mine twice before I ended up just saying screw it and wrapped the connection to the housing with electrical tape. Doesn't move, perfectly aligned, and it's 100% waterproof. It's also very easy to change out in case a bulb blows. Might not be the accepted way of fixing it, but it works for me.

As for your SES light, if you get it scanned and it's not showing anything major, I wouldn't worry about it too much. Mine has come on in the past, stayed on for about 2 hours and gone away. Also check that your gas cap is on tightly. It's an easy thing to overlook. Happened to me a few weeks ago. The second I put it back on correctly, the light went out in a matter of 5 minutes.

2000 GT Coupe
12-23-2009, 02:23 PM
SES and SVS different lights. The SVS light comes on because something triggers the BCM the SES is triggered by the PCM.
I dont think your light being out of place could trigger it. Nor is that how the auto headlamps are controlled. There is a light sensor under the defrost grill on top of the dash.
Your SVS is triggered when there is an abs problem, though the abs light is normally lit too.
You may need to go to a shop that can access all of the cars computers, BCM, ABS, etc.
This could be something as simple as a bad relay as someone mentioned, Do your Daytime Running Lights come on. They should light up any time your car is started and the e-brake is not pulled.

blondiez24gt
12-24-2009, 08:18 AM
Yea that all works fine. I ended up getting the ring to hold the headlight in there right, and now my bulb is blown? It worked before i took it out and put it back in. I didn't touch it either. I guess I'll try a new bulb and go from there. If that doesn't fix it I'll go get it scanned somewhere that does that. Thanks for the help guys.

scott_c83
12-24-2009, 01:03 PM
on my 99 and 02, the SVS light comes on when i have a turn signal out or a headlight out, but not the running lights