Strange smell [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Strange smell


IanGT99
12-23-2009, 10:30 AM
On my way to work this morning, my car all of a sudden began to smell strongly of Pillsbury crescent rolls. I was concerned, but overly satisfied by this olfactory surprise. I was thinking perhaps it was caused by a hydro coil or possibly the flux capacitor; however, I had just placed two empty beer cans, a banana peel, and three stalks of celery in the flux before I left. I'm pretty sure that's not the issue. The hydro coil doesn't seem to be overheating or disengaging at any particular speed. All that said, does anyone know how I can get this lovely smell to remain in my vehicle permanently? Any help would be greatly appreciated.

GrandAmMe
12-23-2009, 12:56 PM
On my way to work this morning, my car all of a sudden began to smell strongly of Pillsbury crescent rolls. I was concerned, but overly satisfied by this olfactory surprise. I was thinking perhaps it was caused by a hydro coil or possibly the flux capacitor; however, I had just placed two empty beer cans, a banana peel, and three stalks of celery in the flux before I left. I'm pretty sure that's not the issue. The hydro coil doesn't seem to be overheating or disengaging at any particular speed. All that said, does anyone know how I can get this lovely smell to remain in my vehicle permanently? Any help would be greatly appreciated.

:iconfused

SikMindz
12-23-2009, 01:06 PM
I would personally check the blinker fluid first. Low fluid can lead to a bevy of other issues. Also, check your spark coils- if they're bad, coupled with a twisted vegomatic you shoudl probably poppin' (a) fresh batch. Should you have damaged your flux capacitor, you should be able to get into 3rd gear at least and get up to 88 mph. If you can do that you can always go back to a pre-Pillsbury time. Lastly, borrow a jiggameter from your local Rocawear store and check your hydro coils on the passenger side. It should be reading at least 2 jiggawatts per pound per square inch.

homeskillit37
12-23-2009, 02:27 PM
Sik is on the right track. Don't forget to open the Kanuter Valve into the cab to keep that sweet Pilsbury smell coming in all of the time. Its located right below the blinker fluid reservoir.

IanGT99
12-23-2009, 08:15 PM
Now, if I do happen to reach 88 mph with the vegomatic and the kanuter valve fully engaged, won't that possibly harm the inner workings of the doofloppie, therefore effectively rendering the crescent roll smell virtually undetectable???

homeskillit37
12-23-2009, 08:17 PM
you are making this too difficult just make some crescent rolls everyday and throw them in the car, bam your done and have a nice snack

IanGT99
12-23-2009, 08:22 PM
Throwing crescent rolls in the car everyday would cause build-up in the turn signal fluid.

IanGT99
12-24-2009, 08:32 AM
HAHA!!! Every thread in this section is always like, "my wheel fell off" or "my engine blew up" or "every warning light in the car is on." I figure a little off the wall humor would brighten anyone's day who happened to read it. By the way, Sik, I literally almost peed myself when I read your reply... great stuff! lol

As an update, I've tweaked the hydro coils to output 44psi. The viscosity of the turn signal fluid may be a little too thick, but I think this may cause the crescent roll smell to be pumped through the doofloppie via the ignition packs. This should work. I'll let you all know...

[ChaosweaveR]
12-24-2009, 09:05 AM
Wow, you're totally off track. This has happened to me before, it's the muffler bearings. They always give off the sweet smell of cresent rolls when they go bad. Duh.

homeskillit37
12-24-2009, 09:23 AM
well if the muffler bearings put out the sweet smell of cresent rolls. do you have a problem with small animals getting stuck in the rear mout turbo trying to find such a tasty treat? that would be an interesting site coming out the back.

[ChaosweaveR]
12-24-2009, 09:29 AM
That's why I leave antifreeze near my exhaust. Teach those buggers not to mess with my sweet rear mount turbo setup.

IanGT99
12-26-2009, 11:42 AM
I might just try to adjust my air intake tornado a bit.

beavercountyemt
12-26-2009, 11:49 AM
I might just try to adjust my air intake tornado a bit.


do you have it mounted before or after your electric turbo? If it's before that might cause the problems.

IanGT99
12-27-2009, 09:22 AM
No, it's after it, but directly behind my foglight transducer.