Transmission help!!!!!!!! [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Transmission help!!!!!!!!


Ohiojoe
02-26-2010, 01:30 PM
Hey guys, new here, but i may have a major problem....I have a 2000 Grand-am GT-1 150,000 miles ( but it looks like it just came off the showroom floor ) everything has been very well-maintained on this car.... Now the bad, recently the transmission has been slipping and has a very sluggish take-off taching about 3500 rpm and hardly picking up speed but if i drive the car at 70 mph it drives with no problems whatsoever unless i give about half-throttle or more then it pretty much does the same thing as when its taking off...needless to say i havent been driving it much, i have been trying to find out if maybe the pan just needs dropped and have fluid and filter changed or do you think the tranny is shot?

PhantomLover007
02-26-2010, 01:32 PM
Have you ever had the tranny fluid changed?

Ohiojoe
02-26-2010, 01:45 PM
It was a one owner car before me, and i know they had it changed but i think it was around 60,000 when they did..i tried to upload pics, but am having trouble....i know the car has high miles ( i've put a few of them on there myself ) but i bought it because you honestly would think it had 50,000 tops on it..thats how good shape this car is in , would really hate to be tearing the tranny out already

PhantomLover007
02-26-2010, 02:13 PM
Sign up w/ PhotoBucket and post pics from there. It's alot easier.

AaronGTR
02-26-2010, 03:42 PM
No matter how good shape the car looks, miles on the trans and engine are still miles. The transmissions in these tend to wear out faster than the engines. Same as in the grand prix's. Changing the fluid and filter will certainly help prolong the life as it will keep the seals and bearings inside in better condition.... but there is a good chance with that many miles in could just be wearing out. Then again, it could still be ok. Have you checked the fluid level on it or anything yet?

Ohiojoe
02-27-2010, 01:55 PM
I haven't checked the fluid yet, am planning on doing it this weekend, my logic was if I go to the trouble Jack the car up level to check I was just gonna change the fluid and filter regardless...only thing I have done is the day it started slipping I put in about close to 3/4 of the Lucas transmission stuff for slipping.... I know it has high miles, but I think I did good only giving $2500 for it about a yr ago... My luck I was offered $4000 for it a month ago .... Oh well, I love the car and am glad I didn't sell it

Laser57
02-27-2010, 05:48 PM
Most of that transsmission sealer and additive doesn't do anything. Its all marketing and sales. Most people that rebuild transmissions tell you to even use it and that it does more harm than good. It might just be time for a rebuild anyway or to have the bands re-adjusted.

Saber326
03-01-2010, 10:30 AM
you should replace the trans fluid once every 75k miles. did this fix your problems?

Ohiojoe
03-01-2010, 01:04 PM
I had some things i had to take care of this weekend, but i am going to drop the pan and change the fluid and filter within the next 2 days...anything i should look for in the bottom of the pan or filter that may give a clue as to if i have a major problem or not?? I'm guessing the only thing i can hope for is the frluid is burnt up or the fliter is clogged , huh??

GrandAmMe
03-01-2010, 03:31 PM
I had some things i had to take care of this weekend, but i am going to drop the pan and change the fluid and filter within the next 2 days...anything i should look for in the bottom of the pan or filter that may give a clue as to if i have a major problem or not?? I'm guessing the only thing i can hope for is the frluid is burnt up or the fliter is clogged , huh??

Im pretty sure would see a greyish sludge on the bottom if something was seriously wrong. Someone can correct me if im wrong.