Car is sluggish and revs when slowing down? [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Car is sluggish and revs when slowing down?


rx7-5.0
03-02-2010, 06:53 AM
Ok. I've got a grand am with the 2.4L. 163xxx
My problem is:
1. At highway speeds it sputters a little and struggles going up hills. (it does have some pick up though)
2.The exhaust has a little pop pop noise coming from the pipe.
3.When I slow down the car revs between a thousand and 2 thousand rpms. ( for example when Im slowing down around 30 miles per hour the car will just rev five or 6 times then go to normal.)
4.And recently the gas mileage has dropped to around 22 mpg with some highway driving. It was getting about 27 mpg the same driving. (this may have to do with winter tires and using the heater?)

It does have multiple random missfires. ( code p0300)
and it has idle speed higher/lower than expected. (code p0507) the idle is a little high. sumtimes around 1100rpms

Anyways I replaced the throttle position sensor, and it still revs. I have seen it can be a ton of different things from 0xygen sensors to coil packs. (but i dont have $500 to spend in just sensors. lol) Any advice would be appreciated. thanx

hahano404
03-02-2010, 07:10 AM
first check for any vacuum leaks or trash in the intake.
high idle sounds like a vac leak definately

rx7-5.0
03-03-2010, 08:21 PM
I did find a small vac leak an fixed that but it made a very little difference. the car keeps reving up when I slow down. from 800 to 1600 rpms. any ideas?

jaketuff
03-04-2010, 09:59 PM
Only on cold mornings???

rx7-5.0
03-05-2010, 05:52 AM
Nope. everyday it does it when I slow down. warm or cold....its pretty consistent through the day.