Replaced Window Motor But... [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Replaced Window Motor But...


Baundy06
04-08-2010, 07:02 PM
Last fall the plastic brackets that attach to the pulley system in my passenger door and holds up the window broke and the window fell into the door. Since then I had raised the window back up and kept it in place with wedges and tape (it looks terrible but worked). Yesterday I replaced the entire motor assembly, it was almost the same price for a new motor as the plastic clip was, and it functions but I am having a problem.

The first issue are two plastic pieces that attach the window to the regulator. The forward one is still attached with the black tar-like material but the rear plastic piece fell off when the window fell. I reattached the rear plastic piece using a plastic/glass adhesive but does not seem to be holding, can anyone offer a suggestion for what kind of glue/epoxy to use?

My second issue is the window movement, I am also finding that the window goes down very easily and smoothly but when I switch it to go back up, it struggles to the point where it gets the window about halfway up and then stops. Is it possible that the 5 or 6 months of being taped up/wedged caused an issue with the window track? Or do you think the motor is bad/too weak?

Thanks for any suggestions!

KhellendrosxS
04-09-2010, 05:12 AM
If the rear plastic clip is still loose the window is probably rocking out of position and allowing the glass to bind in the track when you try putting it up. Next time press downward on the rear portion of the glass and see if the window goes up easier as you apply pressure. I highly doubt you bent the track by holding the window up as they are pretty stout.

If the above pushing method works look around for a different adhesive. Unfortunately Ill have to let someone whos actually glued those clips back on chime in with what to use.