fog lights [Archive] - GrandAmGT.com Forum

PDA

View Full Version : fog lights


bkwales
04-20-2010, 04:14 PM
My fog lights quit working on me and I was wondering if anyone would have any ideas...
the fuses are fine and the bulbs are new.
Thanks for any input!

Deltabravo03
04-20-2010, 07:55 PM
You could also cheak your relay. Could be a simple relay problem. It happend to me a couple of weeks back. If its not your relay then its a simple break in the wire. The hard part is to find where...

Deltabravo03
04-20-2010, 07:57 PM
Also....Could be your switch.....Ha Now thats a other stoire lol. So i would say make sure your relay is working fine. If it is make sure your got power going to it and leaving from it.

bkwales
04-20-2010, 09:29 PM
switch is fine.. getting power to and the "click" from the right side fusebox.... did all the wiring check this afternoon... didnt think about looking at the relays though... ill give that a shot tomorrow.

Deltabravo03
04-20-2010, 10:00 PM
Ive been looking at the Electrical Diagram and found a couple of interesting things. Turns out when you put ur fog light switch on, it sends a current to the bcm ( Body Control Module) to ground the relay so it " clicks". It also makes the little light on the switch turn on. So that said, if the little light on the switch turns on it means your relay is working fine. That said the problem is between the relay and the lights. But between them the wire passes in the fuse block under the hood. Ill try to pose the diagram so you can undertsand better...