PCM programming help [Archive] - GrandAmGT.com Forum

PDA

View Full Version : PCM programming help


slange22
06-27-2010, 01:33 PM
I have a 99 with cooling problems...replaced LIM twice over the life. Flushed radiator, heater core and block. New t-stat and cap. I can't get the fans to turn on. A/C is shot until I get the $$$ to fix it. Do I have the infamous problem where the PCM forgot about the fans? If so, how and where can I have it reprogrammed?
In Northern California, 102 yesterday...103 today.

lvemy3100
06-27-2010, 01:40 PM
I can't say it will fix your problem but you can always order a PCM from us at MP Racing (www.mpracing.org (http://www.mpracing.org))

Have you checked the fuses and relays associated with the cooling fans?

slange22
06-27-2010, 01:53 PM
I've checked fuses/relays and all seems good. Not sure if i want to buy a new one or reprogram. I'm thinking I can program and lower the fan temp also..

AaronGTR
06-27-2010, 10:34 PM
First question is, what temps are you actually seeing on the thermostat? It is quite normal for these cars to run in the 210-220 range before the fans will kick on, so many people think their car is overheating or the fans aren't working when everything is fine.

slange22
06-28-2010, 01:51 AM
I haven't read temps at the thermostat but, I am in the red on the gauge. Highway spped the car is alright, around town she blows her top.

slange22
06-29-2010, 09:30 PM
I found someone in town to flash the pcm...will that bring back the fans?

AaronGTR
06-30-2010, 04:32 PM
Probably not. Whats in the program is in the program... it's not just gonna stop working and then start working again after a re-flash. Since it is getting into the red without fans kicking on, then there definitely seems to be something wrong. If it's not a fuse or relay, then either the PCM may be bad (output for the fans not working) and need to be replaced, or the fans themselves are shot. See if you can unplug the fans and hook some jumper wires directly to the battery and see if they run.

slange22
06-30-2010, 10:30 PM
I double checked the fuses today...good. Pulled the relays and tested them...good. jumped wires to the fans...good. I did not jump at the relay though, I wired directly to the fan. Power at the relays is ok. Sounds like PCM programming with a lower temp.

MP Racing or Milzy Motorsports?
Is a PCM swap plug and pray or is there programming involved once it is installed?

WidbyJ
07-01-2010, 12:21 AM
*not V6 savvy*

I'd replace the engine temperature sensor(s) before going any further, maybe the ECM is just getting bad data? (especialy so if there are 2)

Also, you mention the a/c is bad, is the wiring still connected? There may be a circuit required or signal missing... Just a bit random but GM does things like that sometimes

slange22
07-01-2010, 12:45 AM
I tested the engine coolant sensor tonight. i compared resistance to a chart I found, and all seems right on the $$$. The A/C...I have a bad compressor seal. Replaced it, charged the system, and it leaked again. Replaced it again, and tore the seal. I decided either a shop fixes it, or my framing hammer. The wife promptly hid my framing hammer.

AleroB888
07-01-2010, 02:46 AM
I tested the engine coolant sensor tonight. i compared resistance to a chart I found, and all seems right on the $$$. The A/C...I have a bad compressor seal. Replaced it, charged the system, and it leaked again. Replaced it again, and tore the seal. I decided either a shop fixes it, or my framing hammer. The wife promptly hid my framing hammer.

Did the fans ever come on when you switched on the AC? Or are you saying the fans don't come on only with AC switched off?

slange22
07-01-2010, 08:05 AM
the fans will not work at all now. They have worked in the past when the A/C was turned on

Robb235
07-29-2010, 07:03 PM
Wire a switch that manually turns the fans on and off.

slange22
07-29-2010, 07:12 PM
Ordered a PCM from MPracing...should be seeing it soon and crossing my fingers.

slange22
08-19-2010, 05:05 PM
Finally received the PCM. No luck. No fans and boils out still.
Gonna try a coolant temp sensor...maybe that will help.

remiljr
08-20-2010, 12:21 PM
What a nightmare! I understand the car likes to normally run at 215 or 220 or so but i think i can tell a performance difference. car runs better when 180 or 200? another thing is why do our cars run these temps when the t-stat is set at 195? and the fans arent programmed to come on till about 230 or something? only time ive seen mine come on was when i was low on coolant! doesnt make sense to me. ?? i want my car to run at the temp the t-stat is set at. wtf.

AaronGTR
08-20-2010, 09:37 PM
It's for emissions and fuel economy reasons. Car burns cleaner when it is hot. The T-stat doesn't just snap open and closed at 195. There is a range where it gradually opens and closes until it's fully open or fully closed. They use a 195 T-stat so that it will be fully open by 200 degrees. 200-220 is the ideal range for the engine. What temp it actually runs at is dependent on the outside air temp because of the capacity of the cooling system. They don't want the fans running all the time because they place more load on the electrical system and the engine which hurts gas mileage. It all comes down to mileage, always. ;) They would prefer to let the normal air flow do the work and only use the fans if the engine is going to overheat. If you care more about performance than fuel mileage, then you can program the fans to kick on earlier... and they'll run all the time.

blazingerbs
08-21-2010, 08:53 PM
sounds almost identical to what mine does. all good on the highway, heats up in town.
my fan only come on when i turn the ac or defrost on. it will run in town and not boil over, just runs 5 - 10 * hotter. are you sure they dont run when your compressor is running? the bower has to be on at least 1

76TA01GAGT
08-23-2010, 02:30 PM
Any resolution stang22? I have a 2000 GAGT doing the exact same thing, compressor is bad, have tried it connected and disconnected (no difference that I could tell either way), fuses are good, fans are good, havent tried the PCM yet....................