I've replaced everything, what's next? [Archive] - GrandAmGT.com Forum

PDA

View Full Version : I've replaced everything, what's next?


gregraisbeck
09-08-2010, 11:16 PM
about 2 months ago my car wouldn't start for me. This was a first for the car. I was told that my bcm was shot due to my aftermarket alarm not being properly grounded. I got a new bcm and had it programmed and nothing. Since then, I.ve replaced the ignition and now a sdm but nothing seems to do anything for me. Now the bcm clicks and the dome light flashes when the battery is attached, stop when i turn key to run position but I have no lights or anything on dash.

Please help me what else can I do to get back on the road?

GA2000GTSpeed
09-09-2010, 12:02 AM
well you BCM probaly was okay. Ever take the starter off and have it tested? Sounds like you might of had a simple fix but made more due to replacing random stuff.

did it turn over or just do nothing before? Did the security light come on before when you tried to start it?

Heres a rule of thumb: when something goes wrong do not blame it on the computer, start simple and work your way back into the complicated stuff.

Sounds like the BCM is programmed wrong or something. Where did you get the BCM? and why did you have to get it programmed?

And when you say you replaced the ignition do you mean that you replaced the ignition switch that the lock cylinder goes into? and what do you mean by sdm?

gregraisbeck
09-09-2010, 07:35 AM
the day the car wouldn't start it wouldn't crank or anything. i had the starter tested and it was ok. the bcm began clicking and the security light was on. I got a bcm from parts.com and had it programmed with a tek2 at a dealership. After the bcm was replaced the car wasn't fixed but the clicking went away. I was told to replace the ignition switch so I did and nothing. I towed the care to the dealer and they said my sdm(airbag module) wasn't communicating with the computer and I needed to replace it. Done that, still not starting,, cranking, anything.

burgett2103
09-09-2010, 09:14 AM
so it doesn't click at all? if you still have original battery, i would suggest replacing that.

any service engine lights?

gregraisbeck
09-09-2010, 10:58 AM
No clicking when trying to start. There was a service vehicle soon light after it first happened but went away after new bcm was programmer. Security light came on so I replaced ignition lock and performed relearn and it went off. Battery is newer, like 2008

Pauljp
09-09-2010, 01:27 PM
To get right down to the basics.
Your starter is grounded to the engine block.
There are two large and one small terminals on the starter solenoid.
One of the large wires is the big red cable going directly to the positive side of the battery, the other goes to the alternator.
The smaller wire comes from relay 11 in the fuse block under the hood.
If you were to put 12vdc directly to the smaller wire at the starter, it should activate the solenoid and the starter should turn the engine.
The engine won't actually start because everything else is off, but at least you will know that the battery, starter and solenoid are fine.
It doesn't have to be a huge wire since you are only triggering a solenoid.
Do it safely and quickly just to see if the engine is turning over.

Depending on what happens, it will tell us several things:

1. If the starter turns the engine then your battery, cables and starter are fine. Now we have to look at the next device up the line, the starter relay #11.
2. If nothing happens, and you said that the starter was tested ok, then the only thing is can be is a dead battery or bad cables, which includes the ground cable from the battery.
3. You should hear the starter solenoid engaging, like a relay click. if not, then it's the starter.

Let us know what happens and we can go from there.
Good luck.