Blinker help [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Blinker help


fastmodena
09-11-2010, 10:37 AM
Just want some advice before I start tearing apart the multi function switch.

2000 GT.

I have had the car for a few months. First the hazards would not work so I replaced the hazard switch and it works great. Now all of a sudden my blinkers are intermittent. The green light always comes on but sometimes it does not click, sometimes it works, and sometimes it will start to work really slow and then work or not.

The weird thing is that if the ignition is ON but the car is not started the blinkers work great. It only happens when the vehicle is turned on and the problem seems to get progressively worse where they the light is on but no clicking.

Multi function switch?
The new hazard switch?
Ignition switch? (Could this be the culprit? At one point I had no electrical and figured out I had to zip tie the connector to the ignition switch for everything to turn on).

Any idea where to begin? I would think the multi function switch but when the car is off the blinkers have no problem working. WEIRD!

Thanks

PhantomLover007
09-11-2010, 01:35 PM
Fuses good? Connections for the MFS?

fastmodena
09-11-2010, 06:08 PM
Fuses are good. I'll have to check the connection to make sure it is good. That is what happened to my ignition switch. The connector was just loose enough to lose all electrical power. A zip tie fixed it instead of a new ignition.

If its not the connection, then what?