possible LIM gasket change? [Archive] - GrandAmGT.com Forum

PDA

View Full Version : possible LIM gasket change?


jeepmudbogger
10-21-2010, 07:48 PM
So, I was told that a LIM gasket change should fix my problem, so I am asking you guys.

Its a 3.4 with 137,806 miles. I have almost no power from about 1500 rpm to 3000 rpm. After it gets past 3000 its like there is no problem with it. I have noticed recently at WOT, it will not rev or accelerate past 4500 rpm. I did notice that the coolant reservoir is ridiculously dirty like there is oil in the coolant. There is no water in the oil. Roughly around the time to change the oil, the low oil light comes on.

Whats really bothering me is there is a metal to metal squeal from around 1500 to 2500 rpm. Noticeably louder and lasts longer when the motor is cold. Oil level is fine and I don't see any place it is leaking.

My dad had an '03 Impala with the 3.4 and he said that his was doing the same thing minus the squeal and he changed the LIM gasket and didn't have a problem with it.

What do you think the problem is?

350rs
10-22-2010, 08:49 AM
sounds like what my car did when my cat clogged up. Start it up and put your hand at the exhaust. should be a pretty fair amount of pressure comming out. If not, might get it checked out.

jeepmudbogger
10-22-2010, 09:07 AM
I know the cat is bad, I am getting the p0420 code and I already changed the rearmost o2 sensor. But I kinda want to wait until I figure out whats wrong with the motor before I change the cat. I've always heard that the cat doesn't usually go bad unless there is something wrong with the motor but I may be mistaken.