Belt freakin squeal [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Belt freakin squeal


99PGAGT1
11-04-2010, 10:10 PM
Ok, so this has been a long and annoying battle with this car. I have a belt squeal, used to be only under high rpms- 2500+, now that the cold weather has set in its chirping/squeaking all the time, faster as the rpms rise.

Ive replaced the belt, the idler pulleys, the ps pump, the belt tensioner and cleaned all the other pulleys. still there.

When i replaced the pump i only took out 2 bolts (left and right sides), thought nothing of it...now realizing their is supposed to be a third bolt on the bottom, im beginning to wonder if thats what is causing the belt noise... Could not having that bolt cause the pump to tilt causing the belt to hit the pulley and make the noise?

Its driving me freaking insane. Im going to get a third bolt from a junkyard and put it in, and see if that does it. Just figured i'd ask.

burgett2103
11-04-2010, 11:02 PM
put some lube on it

3x3
11-04-2010, 11:05 PM
You might want to check your water pump. The bearing when bad can create a squealing noise. Also the weep hole on the water pump can discharge fluid, which is another sign that the water pump is going bad. Signs of course of a bad water pump would be abnormal fluctuations in your engine temps. I hope this helps.

GL

99PGAGT1
11-04-2010, 11:11 PM
Putting lube on the belt only masks the problem if not making it worse. Lube doesnt fix it.

Im pretty sure the water pump is good, no leaking, good temps ect.

Ive narrowed it down to the ps pump area.

99PGAGT1
11-06-2010, 01:15 AM
Ok, so for all of you that have an obnoxious squeal, chirp or squeak from the belt and think its in the power steering pump area...and have replaced your ps pump at some point, check this.

They say to put the pulley on until the pulley is flush with the pump shaft. Bull****. Back it off a few cranks on the pulley puller, and voila...silent. When the pulley is flush with the pump shaft the belt comes off of the alternator pulley, goes in towards the engine to the ps pump pulley, then back away to the water pump. Someones stupid design. Basically pull the pulley off about as much as the width of a penny...couple centimeters id imagine. I think it was three half turns with the pulley puller.

This took 8 months of driving me crazy to figure this stupid crap out. But its fixed, and silent.

gearhead73
11-06-2010, 01:24 AM
ouch...atleast you figured it out

Weman
11-06-2010, 08:47 AM
You are my new hero!!

99PGAGT1
11-07-2010, 12:41 AM
You are my new hero!!

Im assuming this worked for you? haha