Slow warm up [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Slow warm up


fastmodena
01-26-2011, 10:20 AM
00 Grand Am Gt. 104K miles.

My car is taking forever to warm up. It literally is taking like 30 minutes or more for the heater to heat up. The car will go to 110 degrees then take 20 min to get to 150 then another 10-20 min to get up to operating temp. Has not made a difference if it was 20 degrees outside or the other day was almost 50. There is some heat from heater while warming up but not enough to help. The heater heat coincides with the car warming up, it slowly rises.

Once at operating temp the heater works great and I have no other issues, however I usually can't drive long enough to have a warm car.

Any ideas?

Only thing I can think of would be thermostat but I have no clue. Could it be that the warm up is ok and something wrong with the heater itself?

xxbackhillxx
01-26-2011, 10:45 AM
Your thermostat has failed. When one fails it stays open as a fail safe so the engine doesn't over heat. In turn, your coolant begins to circulate immediately once the car is started. It takes forever to get the car started.

Easy fix.

fastmodena
02-07-2011, 12:44 PM
Replaced the thermostat yesterday and all is well now.

Just in case for anyone in the future:

My local dealers wanted $248 to replace the thermostat. Using information on this site and the other grand am site I was able to get it all done from 8 am to 2 pm. I took my time and cleaned stuff as I went along, took out the throttle body and cleaned it, and flushed the coolant a few times.

Like others have said it was not hard, more time consuming. I also removed the battery and tray and cleaned all that. After doing it I could not imagine doing it without the throttle body off.

My .02 anyways.

Thanks xxbackhillxx!

Lab Rat
02-07-2011, 01:23 PM
The wifes wagon also takes forever to heat up. I guess I know how to fix it now. Hope I don't have to crawl around on the floor. It's a 95 Taurus wagon for anyone with that knowledge.