Fog lights do not turn on. [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Fog lights do not turn on.


Terryt
03-08-2011, 03:29 PM
Hey I hope I'm posting in the right section if not I'm sorry I am new to this.

My problem is my fog lights don't turn on when I flip the switch, I hear a clicking when I flip the switch ( I know that is the relay in pass side fuse box) and the light on the switch is on but no fog lights.

Any help would be great.

Stevo
03-08-2011, 04:50 PM
Bad relay switch or bad fuse?

cutlsp
03-08-2011, 04:57 PM
Are you sure the fog lights aren't being kept off by the DRL system? Are you trying to turn them on with the high beams on? They stay off when you have the high beams on.

Terryt
03-08-2011, 05:08 PM
I have checked the relay and fuse.

I know about the the drl system, I do not have the high beams on when trying to use the fogs.
I just can't think of what it could be.

Pauljp
03-08-2011, 07:30 PM
I'm going by the wiring of my 2003 model GAGT.
The fog light switch sends a ground to the BCM, which in turn sends another ground to the fog light relay in the right IP fuse box, sending power through Fuse F 10A (also in the right IP fuse box) to two places,
- the light on the switch and
- directly through the fuse box under the hood and into your two fog lamps.
So, if your switch indicator light turns on and off with the switch, then your relay is functioning properly.
If not, then it is either the relay, the switch, the wiring, or the BCM (or something telling the BCM not to energize the relay, like the high beams).
If the indicator light is functioning, your fog lights are directly in parallel with it, so it must be wiring or both bulbs are burnt.

bricooper78
03-08-2011, 08:36 PM
that was going to be my first question, have you checked the bulbs? i know that sounds stupid, but you'd be amazed how many times that's the problem

Terryt
03-09-2011, 07:10 AM
Wow sounds like you know what you are talking about, thanks for all the info.
from everything you said it sounds like it must be wiring because my switch indicator light turns on and off when I flip the switch and I know that it's not the bulbs they are good, I tested them and they worked fine.

I guess I will take apart the wiring today and see if I can find anything. If anyone has any tips on doing that please share.

Thanks for all the help everyone

Terryt
03-09-2011, 03:58 PM
I got the fog lights to work, found the ground and clean it a little and it worked.

Pauljp
03-09-2011, 05:23 PM
I got the fog lights to work, found the ground and clean it a little and it worked.

Good work, glad to hear it.

GROG
04-18-2011, 02:20 PM
Which ground, and where is it located?