2003 gagt 3.4L Fuel & Idol issue [Archive] - GrandAmGT.com Forum

PDA

View Full Version : 2003 gagt 3.4L Fuel & Idol issue


Niltiac
03-20-2011, 12:30 PM
2003 Grand Am GT 3.4L. I have had this car for over years never had any issues until September 2010. My fuel pump went out on me so I had it repaired, after the repairs I noticed my car was going through alot of fuel. Now at times it has an eractic idol at times (not a constent problem) At times (esp when moisture is present) I will start up my car and it will "buck" with eractic idol, then shut off, I will then start it again and this time it starts but revs up to 5K rpm and stays there until I put the car in drive.

Could it be.....my fuel pump(again but I have a warrenty)? TPC? Fuel regulator?

There are no codes, no fuel smell, no lights........

;crap

GrandAmMe
03-20-2011, 03:14 PM
Its spelt "Idle". Do you have a Cold are Intake? Also, why on earth would you put the car in drive at 5,000 Rpms? Thats asking for transmission detonation lol

Niltiac
03-20-2011, 04:05 PM
Thanks for the ignorance I love it. I'm looking for answers not for a spelling lesson but thank you anyways. Now as for the car starting and reving to 5k and staying there its not the fact that im a complete idiot and go out and drive the car I'm trying to explain a problem.......thanks

stewartfn18
03-20-2011, 06:41 PM
2003 Grand Am GT 3.4L. I have had this car for over years never had any issues until September 2010. My fuel pump went out on me so I had it repaired, after the repairs I noticed my car was going through alot of fuel. Now at times it has an eratic idle at times (not a constant problem) At times (esp when moisture is present) I will start up my car and it will "buck" with eratic idle then shut off, I will then start it again and this time it starts but revs up to 5K rpm and stays there until I put the car in drive.

Could it be.....my fuel pump(again but I have a warrenty)? TPC? Fuel regulator?

There are no codes, no fuel smell, no lights........

;crap
;crap
Thanks for the ignorance I love it. I'm looking for answers not for a spelling lesson but thank you anyways. Now as for the car starting and reving to 5k and staying there its not the fact that im a complete idiot and go out and drive the car I'm trying to explain a problem.......thanks

its not your fuel pump again, thats for sure. i cant think of anything else becuase i really just wanted to post to correct your mispellings

AaronGTR
03-20-2011, 08:05 PM
Well, it's hard to understand the problem when you explain it and don't use English with proper punctuation and sentence structure and spelling. We run across this all the time on here.


Anyway, it definitely doesn't sound like anything to do with the fuel pump. It just turns on and basically runs at one voltage and one speed so it supply a constant amount of fuel flow and that's it. The regulator controls the pressure but that is based on the vacuum reading from the manifold and it usually won't cause an erratic idle. The engine bucking sounds like a possible misfire but you should be getting a check engine light from that. I would get the computer checked for codes anyway. Sometimes there is a trouble code stored in there even though the SES light may not be on. Erratic idle is usually caused by a vacuum leak, or a problem with the idle air control valve or throttle position sensor. To get enough air to rev to 5000rpm though, that sounds more like a stuck throttle to me. Pull the intake tube off and see if the throttle plate is closing all the way or if it's all gunked up with anything. The EGR and PCV both dump into the intake manifold right behind the throttle body and the back of the throttle plate sometimes gets gummed up with oil and carbon residue.

GrandAmMe
03-20-2011, 08:21 PM
Thanks for the ignorance I love it. I'm looking for answers not for a spelling lesson but thank you anyways. Now as for the car starting and reving to 5k and staying there its not the fact that im a complete idiot and go out and drive the car I'm trying to explain a problem.......thanks

Welcome to GAGT.com! I was asking a simple question and stating that you will detonate something in your tranny if you shift from Park to Drive at 5K like you claim. Chill bro.

Edit: Our cars also have a rev limiter of 3500-4000Rpm. You sure its going all the way to 5k?

Malaclypse
03-20-2011, 09:38 PM
Welcome to GAGT.com! I was asking a simple question and stating that you will detonate something in your tranny if you shift from Park to Drive at 5K like you claim. Chill bro.

Edit: Our cars also have a rev limiter of 3500-4000Rpm. You sure its going all the way to 5k?

It may if it isn't in park. I think the rev limiter for neutral is redline. The rev limiter in park is 4k as you say, though.

unchained_01
03-20-2011, 11:33 PM
i replaced a fuel pump with a racetronics and had that issue last summer , thou i dont think it had anything to do with the pump it happened with in 2 weeks of it I had to replace my IAC sensor and while i was at it i replaced the TPC also and cleaned the throttle body and have not had an issue since and mine would idle at 2000 to 2500 when IAC did stick and not throw a code to trip SES light but did show a low voltage spike on a tech II

AaronGTR
03-21-2011, 03:43 PM
It may if it isn't in park. I think the rev limiter for neutral is redline. The rev limiter in park is 4k as you say, though.


Nope, there is a rev limiter (pretty sure it is 4,000 rpm) in park, neutral, and reverse. Unless you have a tuned PCM and requested them changed anyway. So yeah, it's not actually possible for him to be revving to 5k rpm unless it's already in gear and he's moving.

Malaclypse
03-21-2011, 08:11 PM
Nope, there is a rev limiter (pretty sure it is 4,000 rpm) in park, neutral, and reverse. Unless you have a tuned PCM and requested them changed anyway. So yeah, it's not actually possible for him to be revving to 5k rpm unless it's already in gear and he's moving.

That's probably what I was thinking of. Neutral and rolling = redline. I haven't daily driven a GM with an auto since 2005.

AaronGTR
03-21-2011, 08:19 PM
That's probably what I was thinking of. Neutral and rolling = redline. I haven't daily driven a GM with an auto since 2005.


Actually, still nope. lol I know with my stock program at least, even if it was rolling, if the drive selector was in neutral it wouldn't rev to redline. It still stopped at 4k. Could be different in other years. I have mine set to 5k now, but I see no need to let it go to redline in P/N/R.