Quick questions about iat sensor and some other random conector [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Quick questions about iat sensor and some other random conector


icecats87
04-01-2011, 11:36 PM
so most of the time my new transmission is shifting perfect, but occasionally when it shifts its a hard and rough shift and jolts the car, also going from park to drive it slams into gear,

Ive researched it and people have said its the IAT sensor, now do i need to replace the wires to it to or just the actual sensor, if i replace the wires how do i do that?

Also i saw a thread on here for overriding the IAT sensor is it worth it? or is it bad

And where does this connector plug into? the other 2 from this wire went to each fan so where does this one go?

https://mail.google.com/mail/?ui=2&ik=cb2eb56cba&view=att&th=12f14b4f04b1d78f&attid=0.1&disp=inline&zw

icecats87
04-02-2011, 12:17 AM
Okay so forget about the override i looked into it more and its not worth it, second thing i read the IAT sensor shares the same 5V reference as the coolant sensor and the throttle positional sensor, this morning i had read the codes and got a throttle positional one, do you think this means the wiring is bad for the IAT? i was thinking of buying the sensor connector pigtail and new iat and putting it in anyways. what do you all think?

Im pretty sure this is why its causing the transmission to shift hard at times

MAC the KNIFE
04-02-2011, 05:10 AM
so most of the time my new transmission is shifting perfect, but occasionally when it shifts its a hard and rough shift and jolts the car, also going from park to drive it slams into gear...



when i got a new trans in my '99, i couldn't believe how much harder the shifting was, especially from park to reverse and like you said from park to drive.
but it was silky smooth between gears.

i think the trans shift pressure was revised higher during the later half of the grand am prodution, so the new trans i had installed actually is shifting harder, but it's ok.