Mult Problems 03 Grand Am GT [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Mult Problems 03 Grand Am GT


porschia21
04-02-2011, 06:32 AM
Okay

Last year i had a new engine put in my car because i had a cylinder 5 misfire. After the engine was replaced the car was fine for a few months. Then my oil light kept coming on because the car was losing oil. i took my car back to where the engine was done at and they said it was a seal missing which i cant remember the name of. They were supposed to order the part and when i went back the shop has completely shut down with no notice. The engine had a 3 year warranty on it which is now null and void since they went out of business. I still havent had the seal replaced because i'm trying to figure out how to go about dealing with this company. But i'm making sure the car has oil in it at all times. Now my car is puttering when i hit the gas and while it is idle. the service vehicle soon light is on. i took it to autozone and again it is a cylinder 5 misfire. i've already replaced the coil packs and replaced the wires. my car was fine after that but now its puttering/hesistating again. Not sure what to do next. Could this possibly be because of the oil leak? I've put so much money into this car trying to figure out what is wrong with it. Can someone please help?????????

And from time to time my break light comes on but there is break fluid in my car and the breaks rotors and calipers have all been replaced. Is this the wheel bearing again? It seems like every year i have to replace the bearings.

MAC the KNIFE
04-02-2011, 02:50 PM
the brake light is just the hand brake, aka parking brake. that light has nothing to do with any fluid levels.
to test that light, put your car in drive and hold your foot on the brake pedal.
now pull back on the parking brake. 2 lights should come on.
1. trac off
2. brake
it might even make a ding ding ding sound like when the doors are open.

burgett2103
04-02-2011, 02:58 PM
make sure your plug wires are on the correct plugs and coil packs

porschia21
04-02-2011, 02:59 PM
Ok i will try that. because the brake light only comes on when i push on the gas not while the car is idle. I just want to know what is going on with my car and get everything fixed on it.

burgett2103
04-02-2011, 03:03 PM
well first of all, i don't think trac off comes on when you pull up on the e-brake. the only thing that should do anything is your headlights will turn off when you pull up on the e-brake when car is off with key in the on position. all you should see is (brake) i believe. you may have some kind of electrical glitch in there somewhere which is always hard tracking down.

but if your losing oil i have no idea.

porschia21
04-02-2011, 03:10 PM
Thanks I agree it might be something electrical. I also hear a ticking noise in the area by my cd player. it sounds like the ticking when you put on the hazards. the display on the cd player is dim too. so i think the cd player might have something to do with it. it is the factory player. no the trac off doesnt come on when i pull up on the brake. it just comes on randomly when i'm driving or sometimes after i've washed my car.

All that stuff started after the cd player display started to dim. the only thing i've done to the car is replace the speakers with aftermarket ones. maybe that wasnt such a good idea