p0122 code tps low circuit (may be caused by rear o2 sensor) [Archive] - GrandAmGT.com Forum

PDA

View Full Version : p0122 code tps low circuit (may be caused by rear o2 sensor)


icecats87
04-02-2011, 05:10 PM
When i took my engine out to do tranny swap i forgot to unplug the rear O2 sensor so the 4 metal prongs ripped out, if i line all 4 of them with the connector will they go back in? also could this cause the tps code cause im getting no acceleration right now and was wondering if that O2 sensor was causing it since its not running the loop of everything

icecats87
04-02-2011, 08:02 PM
I bought a new TPS sensor and how do you adjust it or calibrate it?!?!?!? if i lossen the screws it wont move because there is a plastic piece on the TPS that goes into the throttle body so i need to remove screws to even move it at all, so when i do that and turn the tps i get it to volt specs, but it doesnt go back on to the bolts because the plastic piece isnt lined up, ive done it like 6 times sometimes when i tighten everything up i go WOT and there is no acceleration at all, sometimes it idles at 1,500 rpms is there a special way to adjust it for grand ams?

AleroB888
04-03-2011, 05:28 AM
When i took my engine out to do tranny swap i forgot to unplug the rear O2 sensor so the 4 metal prongs ripped out, if i line all 4 of them with the connector will they go back in? also could this cause the tps code cause im getting no acceleration right now and was wondering if that O2 sensor was causing it since its not running the loop of everything

The circuits can affect each other -- for example, I had a bad TPS once that caused a code for the "5 volt line" but not a TPS code, and the gas gauge read zero, and the trans shifted hard. You need to scan the TPS for percent of range, zero % @ idle, and 100% @WOT, and smooth transition.

http://www.grandamgt.com/forum/showthread.php?t=83107&highlight=tps+relearn