Car stutters, and sometime stalls [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Car stutters, and sometime stalls


icecats87
04-08-2011, 02:17 PM
So i was driving my car today, and when i let off the gas the car stutters and the idle drops. It almost feels like it will stall. At a complete stop and i accelerate then let off the gas at low speeds the car will stall.

last week i had 9 engine codes 1 had a bad egr valve and the others were just from my rear o2 and evap solenoid. (ripped o2 sensor out of connector when removed engine i already fixed it) and i also broke off a plastic piece on the evap solenoid. i erased all the codes after i fixed them all but the evap code kept coming on

I got a new evap solenoid from the dealer put it on and im still getting a code for it, now would a bad egr valve cause the car to stutter, rough idle and stall?

hahano404
04-08-2011, 05:26 PM
if it sticks yea. than you have a vac leak and run lean.

icecats87
04-08-2011, 05:29 PM
Now every time i put it in drive the car just stalls when i put the car in park its perfect, i go to neutral its fine, even revers it idles perfect. then the second i go into drive the car just immediately stalls

MAC the KNIFE
04-08-2011, 05:57 PM
weird...
i had some problems from my EGR when i switched from a 99 style to a 2000+ style egr valve.
the car would stutter it's way through low rpm in 1st gear, but beyond 1st gear or low revs, it was normal.

but i don't know about dying the second it goes into drive; a jammed up trans?

icecats87
04-08-2011, 05:59 PM
I just replaced the transmission 2 weeks ago its been perfectly fine for 2 weeks now all of a sudden it just die when i put it in drive

icecats87
04-08-2011, 06:22 PM
So now its not stalling when i put it in drive but when i do put it in gear it slams into drive. it shakes the whole car and just doesn't feel good i went from park to drive 10 times it stalled twice and one time it almost stalled. the car is warmed up i honestly dont know whats wrong