G.A clicking noise. (video included) [Archive] - GrandAmGT.com Forum

PDA

View Full Version : G.A clicking noise. (video included)


Trevor865
04-15-2011, 12:24 PM
There is a clicking noise when you first start up the G.A but it fades away after the car has been idling for about 45 seconds as you can see. and it will occasionally do it when i first take off at a stop light or give any pressure on the throttle. I have had it looked at before and mechanic said he didnt know what was causing the sound. Anyone know what could be going on. could it be a leak in the exhaust or header?

(Video)http://youtu.be/JMMWXq_yups

juanvan
04-15-2011, 01:55 PM
Does not sound like exhaust
He does not have a stethoscope to listen to area's of the car that could be making the noise?

That is what you need - I would look at your belt area as it sounds rotaional

Trevor865
04-15-2011, 08:26 PM
yeah i have checked all of those man, its been clicking like that for like as long as i have had the car, but never really thought anything about it. and on top of that my SES light came on while i was on my way back home tonight. i would really like to find out what the noise is man. and when you open the hood to listen to it it sounds like its coming from the back of the motor. oh and i have a 2.2 ecotech if that helps any.

Trevor865
04-16-2011, 08:48 PM
Bump, anyone might know what is going on? c'mon now.

FutureDC_FLY_GT
04-27-2012, 04:40 PM
Hey was wondering if you ever figured it out..?

UndeadGods
04-27-2012, 08:38 PM
Video doesn't work for some reason =/