Battery issue? [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Battery issue?


gabriel1985
05-05-2011, 01:17 AM
When I press the door lock button on my key fob the doors lock but the horn barely makes a sound and when I go to start the car for like a split second it makes it seem as if it's dead but then... boom it starts.The other day I left my lights on and my battery died over night. I got a jump and it was fine for a couple days, held a charge fine. So not sure if this is related or not. Any Suggestions?

WidbyJ
05-05-2011, 08:33 AM
Replace the battery. Generally when an older battery has been allowed to completely discharge it will never really come all the way back to life. The jumping causes internal shorts to develop... I recommend Optima Yellow tops because they can handle being drained lower than normal repeatedly. The redt tops seem to be of lesser quality the past few years for some unknown reason.

Of course, thoroughly clean and tighten all connections first and closely inspect the major cables. You may just be suffering from loose or corroded connections...

gabriel1985
05-05-2011, 11:50 PM
Thanks!!! Gonna Try that asap. I think your right, cause it does hold a charge for like 20-30 minutes after I drive and I have had this battery for a few years with a sound system.I'll try the cables first,but not to sure that's the problem(corrosion) cause I just replaced the battery post like 6 months ago.It's worth a shot though. :) If I take it to a store(autozone) and have them check the battery do you think they will be able to diagnose if the battery is shot or not?

skifreak122
05-06-2011, 06:10 AM
If I take it to a store(autozone) and have them check the battery do you think they will be able to diagnose if the battery is shot or not?

They should be able to.

Stevo
05-06-2011, 09:31 AM
Yes Autozone will be able to tell if the cells are bad, but their reading are not always correct so even if they say its good, just go ahead and replace it. I took an alternator up there once, and they said fine, replaced it anyway fixed the problem so it just depends but its usually correct.

gabriel1985
05-07-2011, 02:06 AM
you guys are amazing. they said my battery was shot. Replaced it and everything is running perfect.Thanks a bunch guys!!!