Need some ideas [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Need some ideas


Shade2012
06-13-2011, 11:52 AM
Alright so my SES light came on yesterday. Went to my dads work and got the car scanned. This is the result:

P0442 - EVAP system small leak detected
U1040 - Loss of EBCM/EBCM communications
P0440 - EVAP emissions system fault

I know the P codes can be caused by the gas cap, and im going to replace it with a locking one that i have in my garage, once i find it. But, what about the U1040 code?
This is the only thing I found with this code:

http://www.gaownersclub.com/forum/showthread.php?t=128209

Any suggestions or tests that I could do to figure this out? I'm not one for going to the dealership to have them fix it. Anything will help, thanks guys.

icecats87
06-13-2011, 02:06 PM
check fuse number 47 under the hood

Shade2012
06-13-2011, 02:29 PM
check fuse number 47 under the hood

Seems to be working fine, the test light showed up. Should I replace anyway?

icecats87
06-13-2011, 03:12 PM
Seems to be working fine, the test light showed up. Should I replace anyway?

wouldn't hurt

Shade2012
06-23-2011, 07:17 AM
bump, anything else? I put a locking gas cap on, cleared it, and the light came back on.

Shade2012
07-10-2011, 11:19 AM
The car wont idle now. Everytime I start it, it stalls. I have to keep my foot on the gas to keep it running. I really need some ideas guys. Anything will help. I cant keep putting my foot on the gas and brake at the same time. Its driving me nuts! :banghead