at wits end with this car.. EGR now? [Archive] - GrandAmGT.com Forum

PDA

View Full Version : at wits end with this car.. EGR now?


350rs
08-07-2011, 01:50 PM
Car will not start unless giving it gas. The last time it did start without any assistance it ran at about 300 RPM again. Its like there is a HUGE vacuum leak somewhere. So if this EGR system isnt closing or opening will it cause it to do something similar to this problem? Also have considered my IAC. But its not that old and should be ok. No codes or anything to go off of either. I do not have any way to test fuel pressure here at school either. Im scared to go home because the way home is twisty curvy roads with about a 400 mile drop on each side to my death. If i lose power on that road, im a goner.

I should note that when im giving it gas its running fine. No sputters or anything. Runs like nothing is wrong. But as soon as i let off the gas, dead.

MAC the KNIFE
08-07-2011, 02:16 PM
my car always starts better when i apply throttle when turning the key. otherwise, it'll just keep turning over without firing up.

but if it's up and running, and still dies when no throttle is applied, that could be an IAC stuck closed. you might unscrew the IAC valve and take it out, and use some proper tape to cover the hole. see if it will at least stay running this way.

it shouldn't be the EGR malfunctioning. if that was stuck open, you'd actually be getting some air into the manifold, but it sounds like your problem is not getting enough air.

might be a filthy fuel line filter? how does it run if you just keep your foot on it a little and don't let it die? in other words, is the problem just at low RPM? have you tried goosing it to make sure things are ok at 3000 rpm or so?

HOYS
08-07-2011, 02:29 PM
I'm calling IAC on this one.

350rs
08-07-2011, 02:54 PM
That would tick me off. On my third one since i bought the car now. Not even three years ago. Granted that may not have been the problem the several other times i replaced it. Ill try and find a set of star keys ( maybe the room mate has some) and pull it out and try cleaning the pentle and seat.

Is it reccomended to clean the MAF with a bit of rubbing alcohol and a q-tip and a steady hand? I have MAF cleaner at home.. 100 miles away. Wouldnt hurt to give it a clean either way so.

Lab Rat
08-07-2011, 05:22 PM
Don't touch the maf. Spray it with maf cleaner, then spray again and let dry. They break easily but make a world of difference when clean.

350rs
08-07-2011, 05:36 PM
well i got the IAC out, cleaned it. Nothing changed. i guess all i can do now is replace it, again.. if thats not it though, any other ideas?

MAC the KNIFE
08-07-2011, 07:41 PM
dont touch the MAF x2!

while you had the IAC out, i would've covered the hole it left in the throttle body, and saw how it ran. that would let me know if it was the IAC broke shut or not.

350rs
08-07-2011, 07:46 PM
already cleaned the maf. its done and fine. however the IAC is still messed up.

350rs
08-08-2011, 11:49 PM
changed iac again and all is fine as assumed by all.

HOYS
08-09-2011, 12:01 AM
changed iac again and all is fine as assumed by all.

What do I win?

Lab Rat
08-09-2011, 05:23 AM
You win our thanks. I went through this with my 2.4 twin cam. I actually have 3 IAC's, they all made my car run like crap.One of them is brand new. But my kids 3100 has had me chasing the OP's original problem. Maybe I'll get one from NAPA instead of the crap I got from Autozone.

350rs
08-09-2011, 07:08 AM
What do I win?

a pat on the back? how about a round of applause :applause:

Lab Rat
08-09-2011, 03:06 PM
One last comment. Decided to clean the MAF before dropping more cash. Starts like a new car now. Just FYI.

HOYS
08-09-2011, 08:19 PM
One thing with changing IAC's...

The plunger is actuated in a spiral motion, not just in and out. I've seen people change them and JAM the plunger into the housing...and then they are broken...