Electrical issues now =( [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Electrical issues now =(


icecats87
09-15-2011, 10:56 PM
So many of you know i just installed new headers. heres some info. On September 4th, i start and took the whole day to remove old headers completely. (battery unplugged) Yesterday i finished the install and went to start the car, but the battery was dead. I bought that battery in april, so its around 5 months old.

Yesterday after it was dead i put it on the charger. once it was charged i fired up the car (first start after install) everything was fine, it was loud because i was running open headers but everything looked good.

Now this morning i went outside to start the car to go to work. guess what? the battery is dead again. so i put it on the charger and tried to start it again. the car wont start. it cranked and cranked but just didn't start.

Here is where it gets weird, i would press my brake Pedal and all lights would turn off and the gauge needles would just drop (key was in "on" position) so it seemed like if i hit the brake all power would be drained, if i let go of pedal the lights would turn on and gauge would move.

Took the battery in to work and had it tested, and it was good and i topped it off with the charge. Now i haven't replaced the starter ever in that car so i bought a new one, installed it and still not start it just cranks and cranks and cranks but wont start. you can hear idk backfire? from where the headers are open, then it will smell like exhaust fumes. 20 minutes ago i went out and checked fuse #37, looked it up online some people had this problem that fixed it, well it didnt fix mine. i replaced it went to start and nothing. I took the key out and opened the door, but my headlights stayed on, radio was on, interior lights on, gauge cluster on. wtf? there is no key in and doors open but there all getting power. so i tried cranking it didnt start then they all turned off. Now if i manually turn my headlights on and off the doors will unlock, anyone have any clue whats going on?

AaronGTR
09-16-2011, 08:10 AM
Almost sounds like a bad BCM. It's hard to say with that many symptoms.

icecats87
09-16-2011, 08:49 AM
Almost sounds like a bad BCM. It's hard to say with that many symptoms.

Any way to test if the BCM is bad? And why would this happen over night? Wednesday car was turning on and i was able to drive it and everything, then all of a overnight batter was dead and all this crap started happening

icecats87
09-16-2011, 09:35 AM
so im thinking its the BCM for sure, im getting spark, im getting fuel. I talked to a few shops i deliver too and everyone said BCM. They said unplug battery, plug it back in turn key to "on" for 10 minutes then try start it. if it doesn't work i should just get a new one. I can get a new one from work for 80 bucks. where exactly is the BCM? and do i need any programming on it or is it just a "plug and play"

I really want to drive my car! it kills me to have it sit for 2 weeks, and sucks even more when i have new headers sitting in begging to be driven!

juanvan
09-16-2011, 12:42 PM
BCM is the body control module - yes you need it to run the car.

If you have spark and have fuel the next thing is checking compression.

icecats87
09-16-2011, 05:03 PM
It works!!!!!!!!!!!!!!!!!!!! disconnected battery the reconnected it, turned key on then cranked it for couple seconds left it in "on" for 6 minutes security light was blinking 6 minutes later went off, turned key off for 10 seconds and it started right up! now time to get cat welded on =)

AaronGTR
09-16-2011, 07:47 PM
Well, unplugging the battery won't really do anything. The only thing that resets is the fuel trims and the trip odometer. Doing the 10min key on 10min key off routine is for the security system built into the PCM/BCM interface and that would probably help it start. That usually points to a problem with the ignition switch or PCM, but it could be related to a BCM issue too since the security code needed to start the engine has to match between the two computers. All the other weird electrical problems would be related to the BCM though. I'd still get it checked out or replaced.

icecats87
09-16-2011, 07:52 PM
Well, unplugging the battery won't really do anything. The only thing that resets is the fuel trims and the trip odometer. Doing the 10min key on 10min key off routine is for the security system built into the PCM/BCM interface and that would probably help it start. That usually points to a problem with the ignition switch or PCM, but it could be related to a BCM issue too since the security code needed to start the engine has to match between the two computers. All the other weird electrical problems would be related to the BCM though. I'd still get it checked out or replaced.

PCM is pretty new i got a tuned one last summer