Battery keeps running down [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Battery keeps running down


handon
11-09-2011, 01:27 PM
I just recently broke my foot (about a week and a half ago) and I haven't been able to drive since, but I just went out to my car for the first time yesterday for the first time in over a week and my car was completely dead (I mean not even enough to turn on the LED dome light - gone.) I thought that maybe I had left the key on or lights etc so I jumped it with my mom's car and let it run for about 10 or 15 minutes and turned it off, ensuring and double checking the position of the key and headlights etc, everything, and went inside. Well I went out there just now and it was dead again. At this point I was a little confused and kinda pissed, but then I realized that den fter I pull my key out and open the driver's door (to turn off things) the digital mileage indicator and low fuel light and various other dash lights are still on, as if the key is in the 'on' position, but whenever I actually do turn it to the 'on' poison, EVERYTHING goes off, and I can't even get the motor to click like it wants to start. I'm so confused..

Oh and yes I did try to search for this but the only thing I found was some guy that had issues after his headers install, but it doesn't sound too similar to my issue..

I also have a wheel speed sensor that's bad if it has anything to do with anything.

Btw, it's a 2 dr 02 GA SE

Pauljp
11-09-2011, 01:36 PM
Charge up your battery and disconnect it from the car, leave it for a while and reconnect it and see if it will start. If it is dead then your battery is not holding a charge and you will need a new one.
Start troubleshooting at the source - the battery.

handon
11-09-2011, 01:49 PM
Thanks, I'll try it when I get home and see what happens

Pauljp
11-14-2011, 09:46 AM
So??? What's happening??