power steering [Archive] - GrandAmGT.com Forum

PDA

View Full Version : power steering


harmlessmcfly
11-26-2011, 05:18 AM
Hi guys/gals. Long story but going to condense it. 2 years ago, I had a new ps pump put it cause it had a leak and ran out of fluid. Then same problem. Did both lines. 6 months later, no more fluid again. Had a refurb rack put it and new pump. Now, 2 years later, I'm on my 4th ps pump, second set of lines and 2 racks. What's wrong here? I keepp bringing it back to the same place cause its warrantied but its pissing me off. I had the rack, lines and pump replaced a week ago and last night I hear a whining when I turn the wheel. So I check the fluid and its almost bone dry. I just paid $650.00 for the rack, alignment and outter tie rods. I'm gonna bring my car back, demand my $650.00 back cause the mechanic said "ill warranty thr pump and lines. Ill put gm parts in instead of aftermarket cause they don't seem to be lasting. Also, there is fluid everywhere and ur rack is leaking. If you don't do the rack, I can't warranty the pump". So here I am after doing the rack. Still leaking...still pissed off. Car is a 1999 grand am gt. Please seeking advice.

AaronGTR
11-26-2011, 08:44 AM
I dunno, but it sounds like they are doing something wrong to me. My steering system has never leaked, and I haven't heard of that many people having problems with them either. Occasionally someone will have a leak (can happen to any car) but it's not a really common problem like the LIM gaskets.

Only thing I can think is that they didn't bleed all the air out and fill the system all the way like they should have, or your cap might be missing the gasket, but then you'd see fluid all over the outside of the reservoir and it still probably wouldn't be totally empty.