Help! Any ideas with what's wrong with my car? [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Help! Any ideas with what's wrong with my car?


xINVICTUS28x
01-04-2012, 07:14 PM
For the past few weeks my car hasn't been starting up right. Sometimes it will start right up, but more and more lately it takes like 5 times of turning the key and trying before it starts up. The engine cranks and everything. Sometimes it even sounds like it started but then dies instantly. Other times it will start up, almost die, then rpms will go up to normal. No lights have came on or anything. I really have no ideas. Also as a side note, when I'm driving my car it runs good, but sometimes when I stop at a stop light the engine will kinda jump and jolt? It's hard to explain. It's almost like the gas is quickly cut off then released back to the engine. Not saying that's what it is at all. Just trying to explain the feeling. I feel like the problems are connected but I'm probably wrong. Anyone have any ideas??

chris_gt_74
01-04-2012, 07:23 PM
Bad fuel pump?

xINVICTUS28x
01-04-2012, 07:48 PM
That's what I thought at first. But when I read a little more about how to identify a bad fuel pump, people said the car would run rough while it is being driven too. Plus when I drive and ref my engine the fuel gets there just fine.

Fireball
01-04-2012, 07:50 PM
Could be a malfunctioning IAC valve?
How is idle?

How is WOT acceleration? May be a clogged fuel filter (WOT would reveal this very easily though, if the car performs fine at WOT this likely isn't the problem).

xINVICTUS28x
01-04-2012, 08:21 PM
WOT acceleration seems perfect. Idle runs fine. Just seems to choke up when I'm at a stop.

xINVICTUS28x
01-04-2012, 08:31 PM
That's whats got me stumped. It runs perfectly fine when I have the pedal down and in idle. It's just starting it and when it sits still.

street_fire
01-04-2012, 08:32 PM
Change fuel filter, clean air filter, clean MAF senser and change the PVC valve.

HOYS
01-04-2012, 09:24 PM
Sticky IAC or clogged passage is where I would start looking, its free to check and hell might as well...

xINVICTUS28x
01-04-2012, 09:25 PM
Thanks chaosweaver. That sounds like it might do the trick. I'll try it tomorrow and let you know how it goes.

MAC the KNIFE
01-05-2012, 05:21 PM
ive had this startup problem for a very long time. i slightly press the accelerator pedal when i turn the key now and it works every time.

also, the surging happens to me a lot too. sometimes when i come out of a tight turn like a u-turn or moving through a parking lot and sometimes when i brake to stop. i just think its the norm

xINVICTUS28x
01-05-2012, 07:34 PM
Ok so I wanted to check the WOT again just to make sure it was fine, and now it's starting to stall after 60 or so...?

Lab Rat
01-07-2012, 04:55 AM
I had never thought a dirty injector would be a problem but a bottle of fuel line treatment and a few hundred miles has fixed this problem completely. Might be worth a shot.