Decided to Finally See Whats Up [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Decided to Finally See Whats Up


semborski
01-06-2012, 01:40 PM
So my horn hasn't worked since i've had the car in august. It works on the remote lock just not from the steering wheel switch. So right now in the midst of taking it apart, to see what it could be. Since there is no tutorials or information on this at all. I know its not the horn itself or a relay/fuse or anything because it works on the remote lock. So anyone have any idea on what it could be? Or for that matter even a picture? Thanks for any help.

Update 1:
While I was taking the T30s out of the airbag to remove it, one was missing. Its not a normal bolt though, how could i get a replacement?

Update 2:
http://i977.photobucket.com/albums/ae252/semborski/IMAG0069-1.jpg

^^ The part circled in red, I removed for now. Seeing exactly what it is.

http://i977.photobucket.com/albums/ae252/semborski/IMAG0068.jpg

So could anyone help me with this? I dont know what the switch for the horn looks like or is located.

Also sorry for all the posts.

whiteGT99
01-06-2012, 06:47 PM
the part circled in red is where the airbag pops or clicks into to keep in place so you need those, and from my experience with the horn there is a gold circle behind the steering wheel itself that when another gold piece touches it the horn goes off, my got twisted and bent to crap when i replace my dash and took it all apart so my horn is non existent now

tw0123
01-06-2012, 08:58 PM
if I remember right, the small hole on the bottom of the wheel right above the wire harness is where the horn wire goes. It is a long red wire with a spring around it attached to the back of the airbag piece that lifted out. From what I have read on different forums, there is a spring loaded lever on the wiper/signal piece that has to be flipped a certain way for the horn to essentially be connected, as well as the grounding wire that gets screwed into the back of the wheel...

Lab Rat
01-07-2012, 04:48 AM
A common problem when someone changes the multi switch. Straighten the metal ring and be sure to push in the pin before reassembling. Otherwise you will have to find the broken wire.