Coolant/Heater issue [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Coolant/Heater issue


szwastra
02-29-2012, 01:33 PM
Ok, I cannot find whats up with this heater stuff. I have a 2001 GT.

I replaced the coolant reservoir and cap, did a coolant flush and a refill....but my heater still does not get hot, only when driving on the highway with constant acceleration (then it gets hot and then cold...and then hot then cold). I also have to refill coolant everyday as it is coming out of the overflow hose.

Is it a fan relay switch? water pump?? heater core??? Any ideas where to go next....

KillNThrill24
02-29-2012, 01:34 PM
thermostat

szwastra
02-29-2012, 02:01 PM
Thermostat was replaced as well 2 months ago...forgot to mention

zukiracer19
02-29-2012, 03:43 PM
heater core maybe??? thermostat would make his car overheat.

szwastra
02-29-2012, 04:02 PM
Yeah, not sure but car is not overheating...i think its getting blocked in the heater core or something...but then why is coolant reservoir overflowing too?

zukiracer19
03-01-2012, 01:41 PM
hmm did you put too much coolant in?? bleed out the system properly? car isn't overheating, so... i'm not really sure.

szwastra
03-01-2012, 01:52 PM
Nope, bled and burp the system 3 times...not sure whats up. heat works fine while driving on the highway at full speed but on surface streets it goes warm/cold, warm/cold and never gets hot....and then spews coolant out overflow.

zukiracer19
03-01-2012, 02:17 PM
Maybe the thermostat is just sticking, do you notice your gauge get colder?

PSKpsu
03-01-2012, 02:48 PM
Check to see if your heater lines have been clogged or if the heater core is clogged. pull both rubber lines off from back of the engine and run some compressed air through the lines and heater core. just be sure to not use to much psi so you don't damage the heater core.

Also does your temp gauge raise up while the car is just sitting at idle after awhile?