Headlight/fog/blinker probs [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Headlight/fog/blinker probs


Paulkenosha
04-29-2012, 11:17 PM
Ive looked and can not find anyone with this issue except a very old post where the op never replied with the fix.

So I bought a 03gt with 85k, blinkers blink rapid and flash in front bothsides like hazards are on when the headlights are on, when the headlights are off they work fine. Foglights come on very dim, but light up the parking lights bright, horn dont work, drl dont work. Ive checked all fuses in the car and they are all fine/correct. Also all the bulbs I just replaced thinking that would fix it. Please help if you know whats wrong I am thinking I bought another nightmare car.

sleepyalero
04-30-2012, 12:36 AM
it could possibly be a bad ground.

UndeadGods
04-30-2012, 08:21 PM
Ive looked and can not find anyone with this issue except a very old post where the op never replied with the fix.

So I bought a 03gt with 85k, blinkers blink rapid and flash in front bothsides like hazards are on when the headlights are on, when the headlights are off they work fine. Foglights come on very dim, but light up the parking lights bright, horn dont work, drl dont work. Ive checked all fuses in the car and they are all fine/correct. Also all the bulbs I just replaced thinking that would fix it. Please help if you know whats wrong I am thinking I bought another nightmare car.

How did it pass the safety test if the horn doesn't work? lol

DRL don't work? Did you check your relays?

Paulkenosha
04-30-2012, 09:48 PM
Yes checked relays and even swapped them with ones i grabbed from picknpull. Hell if i know how it past the safty. They are putting in a new headlight/blinker/wiper part into the steering wheel talked to them today, but if thats not the fix then I hope they are going to continue till its fixed.

If anything im glad the drl dont work lol, but the rest I want and obviously need.

UndeadGods
05-02-2012, 05:29 PM
Yes checked relays and even swapped them with ones i grabbed from picknpull. Hell if i know how it past the safty. They are putting in a new headlight/blinker/wiper part into the steering wheel talked to them today, but if thats not the fix then I hope they are going to continue till its fixed.

If anything im glad the drl dont work lol, but the rest I want and obviously need.

Tell us how that turns out!

Paulkenosha
05-05-2012, 06:22 PM
OK just to update what fixed this issue incase someone else gets the same problem.

The Multi-function switch (turnsignal/wiper) was replaced and that did it. All back to normal and everything works like it should. There was a short in the old one.

UndeadGods
05-06-2012, 07:41 AM
OK just to update what fixed this issue incase someone else gets the same problem.

The Multi-function switch (turnsignal/wiper) was replaced and that did it. All back to normal and everything works like it should. There was a short in the old one.

I bite myself for not suggesting something so simple haha