Question about damp weather performance and timing chain... [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Question about damp weather performance and timing chain...


dagenais
06-03-2012, 08:44 PM
Maybe stupid but need to ask...

So it's been raining for about 3 days and today I was on out and of course lots of puddles... I notice after about 30 minutes of driving in hitting a few big puddle, the car had some hesitation, with no power... drove for about 5 minute (no puddles) and pulled over check CAI and other things just to see... everything was fine car drove better after about 3 hrs of sitting the car was back to being normal... So what did I get wet that could affect the performance? Is that a warning to change it? The top of the engine and front plugs and coils were not wet... But could not see the back plugs and not sure if the back plugs are protected from water???

The other issue is timing chain - when I asked the local shop he said no point the change it unless I'm doing some kind of work in the area... he said it's not like a belt that must be change to preventive maintenance? Would you think???

chris_gt_74
06-03-2012, 09:20 PM
You probably splashed a little water on the cai and it sucked it up making it choke a bit. As for the chain that's really an issue of whether you want to replace it right away. I have about ~90k+ on my car and I just changed mine because I was getting an audible metallic rattle from the chain area when over 2k rpm's. It was loud enough to be heard from inside the car. I was afraid of it breaking or jumping time eventually. When I went to replace it the chain was stretched though not as badly as I expected. The damper was fairly worn too with a decent groove worn on both sides where the chain rubs. So I would say if you are 100k+ you may consider it but it's not a sure fire you have to.

sleepyalero
06-03-2012, 09:28 PM
yeah, most likely you sucked it up the intake. i have a cai on my car, had bad rain one day on the highway... right when i got off my exit.. it died. turned back on, and it bogged for the next 20 mins. id remove the intake and dry the iat, the piping, make sure the maf is dry, and make sure there is none sittin in your stock hose that goes from the tb to the cai, (thats if you have a 2 piece, not a 3 piece cai) i have a 2 piece and took off the accordian lookin rubber piping that the iat goes in and there was water sitting in therer because the slopes. after i dried everything it ran fine.

AaronGTR
06-04-2012, 04:10 PM
You might have pulled some moisture into the intake and got the MAF wires wet. It happens sometimes. I had this happen while riding in a friends truck once during a rain storm and it started running really crappy all of a sudden. I had him pull in a gas station and turn the engine off, then turn the ignition to "on" without starting it and let it sit for 10 minutes. Keeps the MAF wires hot and lets them dry out.


As for the timing chain. The mechanic is correct, in that you don't necessarily have to change a timing chain at a certain mileage the way you do with a belt as preventative maintenance.

However... it is still possible for a timing chain to fail however, and the timing chains on these engines are known to stretch out and get a little loose with age or increased HP and rpm. If say you were running a bigger cam with stiffer valve springs, it would be a good idea to change the timing chain out for a new one, or even switch to the 96-99 timing set which has a thicker chain. If you are running a stock cam and springs, and if you aren't running higher than stock rpm, you can probably leave it alone. If the engine has high miles though, and you happen to pull the timing cover off for some other kind of repair, then it would be good insurance to get a new chain. They are cheap, and it's worth the peace of mind.

dagenais
06-04-2012, 05:17 PM
Thanks everyone... Things are good today - So I have learn to leave the puddles to the kids to play in...

Thanks for the piece of mind about the T-Chain... If I decide to change out my U/LIM then I'm thinking just doing an overall upgrade... Have 150K yes it's 9 years old but would like another 4year out of it... Next summer Im taking all body molding off to check for rust etc and repair body / paint...

Thanks