HELP!! 2.4L problem!! [Archive] - GrandAmGT.com Forum

PDA

View Full Version : HELP!! 2.4L problem!!


themanytoys15
06-25-2012, 08:32 PM
I have a 1998 Grand am 2.4 4cyl. Well today my older brother pulls up to my moms house and right away I heard something wrong with the car. Well first of all it sounded like the car was misfiring, he then drove inside and the car sounded very weak, like it wanted die. I popped open the hood and listened for anything leaking, nothing, so at idle the car is fine. Then, I pressed the throttle and I then the car( I wanna say It felt like a misfire) shaked a little. Could it possibly be the modulator or the spark plugs?

[ChaosweaveR]
06-25-2012, 08:38 PM
First things first, is the SES light on? I'd imagine it is, if it does sound like a misfire. But it could be one of three things:

Misfire: one of the spark plugs are bad due to old age/mileage, oil leaks and/or improper AFR

Bad fuel injector: this perfectly emulates a misfire, pulling SES codes will help distinguish the difference rather than second guess

Stuck valve: it's possible a valve has stuck shut due to valvetrain failure. This is less likely than the other two, but run a compression test on all cylinders to verify. Who knows, it might have low compression in all four, and may point out another issue contributing to the misfire.

themanytoys15
06-25-2012, 08:53 PM
Cool thanks I'll check it out, the SES light is broken, but I'll take it to auto zone tomorrow and see what they tell me