99 Grand Am GT Sedan warning light problems? [Archive] - GrandAmGT.com Forum

PDA

View Full Version : 99 Grand Am GT Sedan warning light problems?


dalefoose
07-22-2012, 06:40 AM
Hi I just got a 1999 grand am gt sedan with the ram air , apon it being delivered i have noticed , the pass tail light , drivers fog/driving light and drivers reverse light are all out "not working" also every warning light in the dash is lit up and not going out , and gas gauge never reads the same , can just sit still in car and it moves to different levels ...can anyone help with these problems please..just got this car and i need to fix so we have a vehicle on the road ..we live in a one horse town and need the car to get to citys for everything ...thanks email dalefoose@hotmail.com

UndeadGods
07-22-2012, 11:24 AM
How did you not notice all of that when you purchased the car?

My first, 99 GA Se, had a problem where the lights weren't working. Any of them, for whatever reason. I had to unplug every last bulb, check them, n replaced the burnt ones (there were a few, but not all). I dont know if something shorted it, but after doing this, n reconnectig them, it all worked fine

dalefoose
07-22-2012, 04:05 PM
I didnt notice as i didnt go get the car i had a friend pick it up for me ...the passengers tail light is not working nor is the drivers driving/fog light but have noticed the drivers reverse light peanut bulb is missing ...would that cause any of the light issues in the dash ? the warning lights i mean.....also the antfreeze is non existent in the resevoir so maybe thats a warning light? and the oil is very low and dirty i noticed supposedly the oil warning light supposed to come on when oil needs changed or low in this model? any help apretiated....thanks

UndeadGods
07-23-2012, 09:10 PM
Check fuses/relays for the lights, they could be shot or pulled out.

Oil light might not come on tho when needed.
Do the oil change, check fuses, check bulbs, add coolant.

dalefoose
07-27-2012, 04:12 PM
Did oil and filter change oil light out , lights still on are service engine , abs, trac , and security.....and pass tail light doesn't work but all 4 bulbs are good and the signal and brake light works on that side and have checked with test light power comes to tail light with each respective light on so could it be a problem inside the black plastic housing where connections are made? if so how much is replacement part ? i am in ontario canada

unchained_01
07-27-2012, 06:21 PM
f you have an abs light /trac light it needs a wheel hub or the BCM needs replaced
get it chercked for codesI

UndeadGods
07-27-2012, 07:53 PM
Did oil and filter change oil light out , lights still on are service engine , abs, trac , and security.....and pass tail light doesn't work but all 4 bulbs are good and the signal and brake light works on that side and have checked with test light power comes to tail light with each respective light on so could it be a problem inside the black plastic housing where connections are made? if so how much is replacement part ? i am in ontario canada

Go to a junk yard n get a new black housing. I had a problem where my signal light on the driver back kept screwin up but the bulb was okay. It turned out to be a problem with the black plastic. It shouldn't be more than 10-15$

As for ABS/Trac Off it could be a broken sensor wire, or infamous wheel hub as unchained_01 stated. Get it scanned to make sure.

As for SECURITY light, thats a very common problem, don't worry about it unless your car doesnt start cuz of it.

dalefoose
08-04-2012, 05:00 PM
thank you guys , i had hub assemblys replaced fixed abs trac light service engine was oxygen sensor in rear manifold and the tail light i fixed took the black housing apart and had to mess with connections it wasnt making contact now just security warning light....
:applause: