Cabin fan causing engine problem... [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Cabin fan causing engine problem...


greddy2race
08-15-2012, 07:48 PM
I have a 99 GT sedan, whenever I turn my air on it causes my engine to surge then stall. It doesn't matter if I use heat or a/c or any part of that whole system, it still has the same problem. If the car is idling and I turn on the fan, after about 45 seconds the rpm,s will jump from 600 to about 2000 then drop low enough that the engine dies. Any ideas of what could be causing this?

Car is also throwing a code that is for the upstream O2 sensor, but not sure if that is related and I don't think it is. Any help would be great cause this one stumps me.

msmith1956
08-15-2012, 09:05 PM
I'd look at the IAC as well, but it couldn't hurt to replace the O2 sensor if you don't know if it's been replaced before. The O2 sensors are only good for about 100k, and will give you better gas mileage if you replace it.

greddy2race
08-16-2012, 09:08 PM
I will be taking a look at the IAC tomorrow, but wouldn't that affect the idle whenever there is a load? Not just when I turn on the blower?

greddy2race
08-16-2012, 09:46 PM
I just noticed something else. If our radiator fans turn on at about 215, then this is also causing my engine to surge and stall. I didn't relate the two issues until I started looking at some of the other threads. So there must be a correlation between the blower turning on and/or the fans turning on that is causing my IAC to act up. Can anyone confirm this idea, or has it happened?

SkiZZor
08-17-2012, 03:11 PM
The fans will kick on instantly if the AC is turned on. Take out the fuse for the fans and turn on the AC to see if it is a problem with the fans or not.