Grand am battery drain [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Grand am battery drain


Gealii
10-29-2012, 08:19 AM
I have an 02 grand am se 2.2 ecotec auto trans. I have been having a problem lately with the battery holding a charge. The battery is brand new as NAPA told me with the cold weather my battery is on the border of dieing so that is replaced. It has ran fine since the battery was placed, but for the first time since i had not needed to drive it over the weekend came out and the battery had lost enough charge where nothing would completely power on and couldn't even hear the starter trying to turn over. Even before the battery it seemed to only happen on weekends where i wouldn't drive it. I checked and made sure nothing was turned on overnight.

Any help with this?

I can drive this weeks on end without problems as long as it doesn't sit for 2 days or more

bricooper78
10-29-2012, 07:20 PM
pull light bulbs out of the trunk and the glove box, two known culprits over the years of being a hidden battery drain.

also, check stereo related things, amps, any new amps? how about the head unit?

Gealii
10-29-2012, 07:54 PM
pull light bulbs out of the trunk and the glove box, two known culprits over the years of being a hidden battery drain.

also, check stereo related things, amps, any new amps? how about the head unit?

just a head unit at the moment it is powering off i think all the lights are off. I will go ahead and pull the trunk and glove box lights never use em anyway.

bricooper78
10-29-2012, 08:24 PM
just to see. also it wouldn't hurt to check that wiring on the head.
does it remember radio stations?

Gealii
10-29-2012, 08:46 PM
just to see. also it wouldn't hurt to check that wiring on the head.
does it remember radio stations?

remember as in presets or the battery died so far it reset? it reset cause the demo wanted to play

I wouldn't know i removed the antenna for aerodynamic gains and use a flashdrive for music. I need to check something whenever Sandy passes through, as the power likes to reset it just resets it doesn't completely lose power.

And yea im kind of a MPG nut, but radio is only thing electrical i've messed with so far. 29mpg with a lot of city driving easily 35mpg hw

bricooper78
10-29-2012, 09:12 PM
yea, does it remember the time and the presets?

i'm wondering if that constant lead may not be leading into something else.

and you have MANY more things than an antenna causing drag bub!

thapunisha333
10-29-2012, 10:11 PM
remember as in presets or the battery died so far it reset? it reset cause the demo wanted to play

i removed the antenna for aerodynamic gains

hahaha :applause:

Gealii
10-30-2012, 05:09 AM
yea, does it remember the time and the presets?

i'm wondering if that constant lead may not be leading into something else.

and you have MANY more things than an antenna causing drag bub!

i know i got smooth wheel covers, air dam, tire spats, weight reduction, its all a work in progress just i didn't use the antenna so it was easy to say it was easy to lose