Any Suggestions [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Any Suggestions


Pride43
03-07-2013, 01:37 PM
I have a 2000 GAGT, and i just got a spark plugs n wires change. Used AC Delco Rapid Fire plugs and some duralast wires. (Prolly a bad combo) Anyways, well got it out the shoo n pulled off but it feels like its jerking a bit. Like figgiting. Lol. Then drives normally. Anything? Thanks in advance

unchained_01
03-07-2013, 01:42 PM
You need iridium plugs for these motors

Pride43
03-07-2013, 02:44 PM
So wrong plugs huh?

rocketfast123
03-07-2013, 03:18 PM
Rapid Fires should run great in these motors. I use these in my 2.4 and our 3100. And I have a set of duralast wires on my alero.

Did they gap the plugs right?

AaronGTR
03-07-2013, 03:45 PM
Rapid fires should be ok. They originally came with a double platinum tip plug, and later on GM switched to an iridium tip plug from the factory. Either style will work as long as it's a good quality basic plug with a single electrode and single ground strap. None of the multi-prong BS plugs that don't do anything.

I have no experience with the wires, but I've heard of the Duralast brand and pretty sure they are decent quality replacement parts for OEM. Basically as long as they are new and aren't dirt cheap, then they should work.


You might want to check the plug gap as mentioned. They should come pre-gapped, but it's always a good idea to check. Should be set at .06". Also make sure they plugged the wires in to the correct posts on the coils. One set of swapped wires would make it run rough.

If it started driving funny right after getting it back from the shop, I'd take it back to the shop and demand they check it out. If it wasn't doing that when you brought it in, it shouldn't do it when it leaves unless they did something wrong or deliberately sabotaged it.