mysterious belt squeak [Archive] - GrandAmGT.com Forum

PDA

View Full Version : mysterious belt squeak


icecats87
04-04-2013, 01:32 PM
This problem has been accruing for almost a year now. Their is a loud squeak near the belt area and it gets louder when i accelerate. Last year i replaced the alternator and put a new belt on, and it stopped the noise for about 7 months. Then it started up again. since then i have used two more belts and have replaced every pulley and yet it still squeaks!!! i have even replaced the water pump pulley, Power steering went out so their is a new p/s pulley as well.

What is making it squeak!?!? its driving me crazy

Hanauer51
04-04-2013, 01:43 PM
make sure there isn't to much pressure and tension, or vise vers not enough tension on the pulley itself. I had the same problem at one point, turns out I actually tightened the belt to the pulley on too much, and it thus caused the squeaking.

icecats87
04-04-2013, 01:50 PM
make sure there isn't to much pressure and tension, or vise vers not enough tension on the pulley itself. I had the same problem at one point, turns out I actually tightened the belt to the pulley on too much, and it thus caused the squeaking.

I tried that before I posted this making sure each pulley wasn't to tight or to loose, still squeaked

buffbison
04-04-2013, 05:39 PM
Make sure the PS pump is working correctly. When my PS went out several years ago, I bought a reman from advance. I had to exchange it three times because they leaked fluid and squealed. Thankfully I knew the crew, they didn't give me a hard time for exchanging it three times.

icecats87
04-04-2013, 06:31 PM
Make sure the PS pump is working correctly. When my PS went out several years ago, I bought a reman from advance. I had to exchange it three times because they leaked fluid and squealed. Thankfully I knew the crew, they didn't give me a hard time for exchanging it three times.

I work at napa so I got a new one for a big discount and unfortunately it was squeaking before it went out :( haha. I swapped pulleys today tried to loosen then a bit and tighten and no luck, I might get a new belt again since it usually fixes the problem for a few months

BrittsBen
04-04-2013, 08:34 PM
My belt always seems to squeak a little. When you guys refer to tighten the belt I thought the tensioner couldn't be adjusted? I figured it the belt tensions were off the only way to fix is the change out the tensioner no?

greddy2race
04-05-2013, 10:14 PM
The pulley on my tensioner started acting up causing the same annoying squeak, and normally if I revved up it went away, until one day I revved up, it went away and so did my belt. Then found out the tensioner pulley disappeared from the tensioner altogether. Replaced it with a new tensioner and new belt... no more squeal.