Brake problems/turn signal problems [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Brake problems/turn signal problems


ottosgrandam
05-28-2013, 10:50 PM
Hi i have 2 problems i need help with

1st my hazard switch clicks repeatly sometimes without the blinker/s even flashing and then other times it doesnt click idk? The recall was already fixed on my vin # though

2nd. My right front brake caliper makes a scrapping noise like its stuck close. But its a brand new caliper, pads, newer rotor, and the pins have been greased with synthetic amsoil, but it still makes the noise

Any help would be greatly appreciated thank you

04GaGT1981
05-29-2013, 05:52 AM
well, sadly im not a brake expert. so i really cant help there.

as far as your multi function switch. theres like 2 maybe 3 screws then it just pops apart fairly easily. theres all kinds of info on it online. i looked up a help file for it too. i just fixed mine long ago and dont totally remember step by step. but basically you open up the column clean the switch up and regrease it. i had this issue briefly like a year or two ago. and hasnt happened again since.


hey look....its right here on this site, they have videos on youtube too

http://www.grandamgt.com/forum/showthread.php?t=50126

sleepyalero
05-29-2013, 06:28 AM
id pop the wheel off, spin the rotor, see if it makes the scraping sound. if it does, try and pin point what is scraping. could be the dust shield?

04GaGT1981
05-29-2013, 12:45 PM
you can fix it without taking off the wheel, had it happen in mine the column cover comes off in two pieces easily exposing the faulty switch. is contaminated grease that causes it, i read all about it when i had the issue. clean it, regrease it with di-electric grease. and it should be fine.

i cleaned mine like 2 years ago now and it hasnt happened again.

T50
05-29-2013, 01:56 PM
@04GaGT1981

taking off the wheel is for the brake issue, NOT the clicking sound..

@op, did you replace the slides for the pads and grease those as well?

eBandit
05-29-2013, 02:43 PM
@04GaGT1981

taking off the wheel is for the brake issue, NOT the clicking sound..


lol

kzulfic
05-29-2013, 02:57 PM
I wound check to see if you put the wear indicator pad on the wrong side. Also could be the retainer clips, I had one that split and caused a scraping/screeching sound.

ottosgrandam
06-01-2013, 10:20 PM
alright thank you guys so much

04GaGT1981
06-04-2013, 06:47 AM
@04GaGT1981

taking off the wheel is for the brake issue, NOT the clicking sound..

@op, did you replace the slides for the pads and grease those as well?


yea, i got a little confused there.