Anyone with a Manual Fan switch 99+ Grand AM? Any Info woud be appreciated [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Anyone with a Manual Fan switch 99+ Grand AM? Any Info woud be appreciated


cjls1z
10-28-2013, 09:01 AM
Hello, I'm new to this board but not new to forums. I spend alot of time on a LS1tech and Corvetteforum. Anyway I always liked the Grand Ams and picked up a 1999 SE at a great price. The only problem with the car is the fans don't come on. I have searched this board and seen that this has happened to quite a few people on the board. Some have solved this with the Caspers fan switch. I would opt for this but it's backordered until the middle of November at 2 places but at the same time I don't want to spend the loot.
When I searched this site I found a write up but it pertained to J-Bodies. If anyone on here could help me out or share some advice i'd appreciate it. I have tried everything and yes the fans get power so I'm think it's a problem with the computer. I could use my tuner that tuned my other vehicles to take a look at it but i don't think it's worth it. Any advice would be appreciated. Thanks

AaronGTR
10-28-2013, 03:49 PM
I've got the caspers fan switch in mine. Only use it for staging lanes at the drag strip though. Don't need it for normal driving 'cause my fans work as they should. I know it's possible to wire in a manual switch without the caspers setup. The caspers just gives a higher speed than the normal high speed fans because it uses a separate extra harness and three relays for extra power (essentially over powers the fans).

What temp is your car getting up to? A lot of people complain that their fans aren't working, but they don't even know what temp they are supposed to come on at. Low speed fans don't kick on until 223 F and high speed at 232 F. :thumbs:

Starglow
10-28-2013, 06:11 PM
You might want to follow the attached guide to help figure out why the fans aren't working before you add a manual switch. This is about as detailed as it gets.

http://www.gaownersclub.com/forum/showthread.php?t=137262&highlight=fans

Nick-G
10-28-2013, 06:21 PM
I tapped right into the wires on the pcm. Just find a diagram and figure out which wires are for the fans.

cjls1z
10-28-2013, 09:37 PM
Thanks for the replies. The fans just dont come on at all not even with the A/C on. If I unplug the temperature sensor the fans will come on and stay on. The BCM was replaced on the car also

AaronGTR
10-28-2013, 10:41 PM
BCM has nothing to do with the fans. They are PCM controlled. Either it's not actually hot enough, or there is something else wrong electrically (bad relay, sensor, etc) that is keeping them from kicking on when they should. I have to double check a few things in my manual and settings in the pcm, but I don't believe it turns the fans on automatically when you turn the A/C on either. Pretty sure it only does so when the outside temp or engine temp is above a certain point and when the speed is below a certain mph. I remember for a fact it turns them off above a certain mph even with the A/C on. I'll see if I can dig anything else up tomorrow.

geldartb
10-29-2013, 03:35 AM
Thanks for the replies. The fans just dont come on at all not even with the A/C on. If I unplug the temperature sensor the fans will come on and stay on. The BCM was replaced on the car also

did you check the big fuse in the fuse box under the hood. mine blew before and the fans wouldn't run as commanded but would still turn on with the manual switch i have.

i'd check the fuse if you haven't yet..