power window problem? [Archive] - GrandAmGT.com Forum

PDA

View Full Version : power window problem?


blondiez24gt
12-30-2013, 05:46 PM
I have had power window issues before, and had to put n a new regulator, and those glue on guides......This time though I went through the toll booth, and started to roll the window back up. It got about 3 inches from being closed completely and made a loud pop noise. The window stopped going up. I rolled it back down, and it worked fine. I rolled it back up again, and same thing, but without the pop. It stops about 3 inches from the closed position every time. I tried helping it up, but it won't budge....Any ideas what could be the issue?

Starglow
12-30-2013, 08:12 PM
Sounds like something happened to the cable mechanism. If the clips had broke you should still be able to pull the window up. The only way you're going to know for sure is pull the door panel off to see what's going on in there....I've had to replace the regulators on three doors in my GA. The front ones I bought new and the rears I got from a salvage yard. Still have a new one for the front passenger side in the box in case it ever goes out.

blondiez24gt
01-01-2014, 11:37 AM
figured it out.....I took the door panel off and everything looked fine, but when it got about 3/4 of the way up the window would slide out of the plastic that is glued to the window. I could hardly figure it out, because it didn't come out of the plastic until it was behind he metal on the door. I managed to get the window popped out of the plastic, and coated it in epoxy, and then shoved it back in the plastic. Then rolled the window up, so there was pressure on the plastic guide. A few minutes of drying time, and its fixed.....I've never had one just break free like that. I'm guessing the cold weather just let the original glue break loose.....