GrandAmGT.com Forum

GrandAmGT.com Forum (http://www.grandamgt.com/forum/index.php)
-   Technical Q&A (http://www.grandamgt.com/forum/forumdisplay.php?f=22)
-   -   P0128 - Coolant thermostat (http://www.grandamgt.com/forum/showthread.php?t=87127)

sugar ray 04-17-2012 04:40 PM

P0128 - Coolant thermostat
 
02 Grand Am 3.4 SES light came on today on the way home from work.

Pulled code with my OBD reader. Getting P0128 - Coolant thermostat (Coolant Temp Below Thermostat Regulating Temperature)

Thermostat a simple replacement, any chance the sensor is TOAST or a new thermostat should cure the problem?? It has NEVER been changed. Probably should have replaced it when I did the lower intake gasket?? No big deal!!

Just lookin for a few experts to chime in here... thanks

shiwnath 04-17-2012 10:09 PM

Is the car getting up to normal operating temperature? When my thermostat went, it was stuck open in the middle of this past winter and I couldn't get any heat and it was staying around or below the 1/4 mark. To be honest I'd start with changing out the thermostat because it's most likely cheaper than starting with replacing the sensor. Plus it couldn't hurt to change it after so many years anyways.

sleepyalero 04-17-2012 10:27 PM

Quote:

Originally Posted by shiwnath (Post 1175716)
Is the car getting up to normal operating temperature? When my thermostat went, it was stuck open in the middle of this past winter and I couldn't get any heat and it was staying around or below the 1/4 mark. To be honest I'd start with changing out the thermostat because it's most likely cheaper than starting with replacing the sensor. Plus it couldn't hurt to change it after so many years anyways.

x2 same here

sugar ray 04-17-2012 11:24 PM

Will attack this within the next few days. Thanks boys!! Will post my results.

sleepyalero 04-18-2012 05:05 AM

not a problem

bmoc0129 04-24-2012 12:38 PM

I wish I knew how to replace the thermostat and sensor...because I pulled the same code not too long ago. Also saw something about an EGR valve.

Have you tried adding coolant (if it's low)? I saw somewhere that someone got their light to go off after doing that.

UndeadGods 04-24-2012 07:05 PM

Quote:

Originally Posted by bmoc0129 (Post 1176032)
I wish I knew how to replace the thermostat and sensor...because I pulled the same code not too long ago. Also saw something about an EGR valve.

Have you tried adding coolant (if it's low)? I saw somewhere that someone got their light to go off after doing that.

I doubt it, my car leaked massive amounts of coolant and the light never went on, blew a head gasket, the light never came on =/ haha

rocketfast123 04-25-2012 09:49 AM

When my friend had the P0128 on his 99 V6. It was the sensor. On cold start the fans would go to full speed after about 2-4mins. And the trans would act funny.

sugar ray 04-26-2012 11:52 PM

UPDATE:

Weird....may be leaning towards a sensor?? After posting.....I went back into my car and cleared the codes (knocked out the SES light) with my OBD2 reader. I realize that kocking out the light does NOT solve the problem. Figured I would do that on my way down to the auto parts store. Expecting the light to come back on. It didn't?? Anyways......picked up a thermostat but have yet to put it in. Drove for over a week with no codes or SES light. Then again today....light was triggered and same code appeared. Cleared the code and all was well again.

It operates at normal temperature. Not over cooling or under cooling. Normal as it should be and still have plenty of heat from the vents. I did both the LIM and head gaskets just over a year ago. It's not losing any coolant internally or externally. Car runs like brand new. This code just randomly pops up about once every 7 days??

WTF??

sleepyalero 04-27-2012 12:33 AM

i could be wrong.. but if you keep clearing the code with the OBDII scanner, it will keep coming back until the problem is solved.

when i replaced my thermostat, i replaced the coolant sensor too. and everything was all fine after that.

HOYS 04-27-2012 01:11 AM

Conditions for Running the DTC

The engine is running.
DTCs P0112, P0113, P0117, P0118 are not set.
The ECT is more than -40C (-40F).
The ECT is less than 78C (172F).
The intake air temperature (IAT) is more than -7C (+19F).
The engine has been running for more than 2 minutes, but less than 30 minutes.
The vehicle speed is more than 24 km/h (15 mph) for more than 1.609 km (1 mile).
The mass air flow (MAF) average reading is more than 15 g/s.

Conditions for Setting the DTC

The PCM detects the following:

The calibrated amount of engine run time has been met.
The calibrated amount of engine air flow has been met.
The calibrated ECT of 80C (176F) has not been met.

Essentially your thermostat has failed and it is designed to stay open when it fails, as to not cause harm to the engine. If you engine does not warm up to at least 176* F it will set the code.

Replace the T-Stat (don't remove the lower bolt fully as the t-stat neck is slotted for that bolt) and go from there. If that does not fix the issue (code will have to be cleared, code will go away after 40 successful warmups) then replace the ETC. I'm betting it is just the T-Stat.


All times are GMT -6. The time now is 09:29 AM.

Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2011 GrandAmGT.com