GrandAmGT.com Forum

GrandAmGT.com Forum (http://www.grandamgt.com/forum/index.php)
-   Technical Q&A (http://www.grandamgt.com/forum/forumdisplay.php?f=22)
-   -   horn not sounding...click sound in fuse box when i press horn on steering wheel (http://www.grandamgt.com/forum/showthread.php?t=77434)

99blackgagt 11-03-2008 08:57 AM

horn not sounding...click sound in fuse box when i press horn on steering wheel
 
my horn isnt sounding when i press the wheel, but it is clicking like its trying to respond in the engine, does this mean the LARGE horn relay in the fuse box is old or out? the small 15 fuse is still good, just wondering if i need to replace the large horn relay

PhantomLover007 11-03-2008 09:41 AM

You might try it. The most relays normally cost about $10.

Exodus 11-03-2008 10:09 AM

The same happened to me once...
Never found out what was wrong b/c I got rid of it before I even got it fixed

AaronGTR 11-03-2008 06:44 PM

Yes, it is more than likely the relay is bad. I've replaced that one before myself. There are several other relays like that in the under hood fuse box so you can try swapping one and see if the horn works. If it does, the relay was the problem. You can get them cheap at most auto parts stores.

gaowners32 11-03-2008 09:34 PM

If you can fix it upgrade....

http://cgi.ebay.com/ebaymotors/Compa...mZ220302466287

http://imagehost.vendio.com/bin/imag...ucts/CT4BS.JPG

TFA 11-03-2008 10:23 PM

Quote:

Originally Posted by 99blackgagt (Post 1039540)
my horn isnt sounding when i press the wheel, but it is clicking like its trying to respond in the engine, does this mean the LARGE horn relay in the fuse box is old or out? the small 15 fuse is still good, just wondering if i need to replace the large horn relay

happened to me. all the fuses were good and the relay was clicking. it started working, then stopped again, then started again. its been working for a few months, but who knows ;crap. i dunno what made it stop, or what made it start again for that matter.

99blackgagt 11-04-2008 07:22 PM

thanks for the replies, i will try switching a relay to see if that is the problem....any other suggestions?

videoman 11-05-2008 09:28 AM

Quote:

Originally Posted by gaowners32 (Post 1039844)

Already have one!

Thanks

99blackgagt 11-10-2008 05:31 PM

I tried switching the relays out, and i put one in that worked....the relay still clicks when i press the horn...something isnt getting power?

Pauljp 11-10-2008 08:25 PM

On my 2003 GAGT - The horn relay #21 is located in the fuse box under the hood.
It is electrically hot all the time thru a 15 amp fuse #43 in the same fuse box.
The relay gets its ground from 2 places, either the switch on the steering wheel or the Body Control Module (BCM) used for alarm or chirping for door locks and such.
Does your horn chirp when you lock the door?
Since you can hear the relay click, and you have already swapped it with a known good one, I would unplug the connector directly at the horn and plug a meter or any thing else that is 12vdc and see if it works when you press the horn switch.
Don't know about your 1999 GA but on mine the horn is located directly behind the passenger headlight assembly. Remove the headlight. The horn & connector are right there.
You may also want to verify that your horns do indeed work. Take a good wire and go directly from the positive side of your battery and briefly touch the horn contact. You can actually verify both horns this way.
Use a good automotive wire for this, horns draw a lot of current and the wire will get hot if its too thin and you will burn your fingers, thats why you should just test the horn quickly.
Let us know how this works for you.

99blackgagt 11-11-2008 08:52 AM

thanks i will try all of those things...and my horn doesnt sound when i lock the doors because i put a new viper alarm system on :) but yeah i really would like my horn to work so i will check those things....i have also checked #43 the small 15 amp fuse and it is not blown...i will see if the horn is shot and post back

99blackgagt 11-15-2008 02:55 PM

bump

Pauljp 11-15-2008 08:29 PM

So 99blackgagt... what's happening?!?


All times are GMT -6. The time now is 11:52 AM.

Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2011 GrandAmGT.com