GrandAmGT.com Forum

GrandAmGT.com Forum (http://www.grandamgt.com/forum/index.php)
-   Technical Q&A (http://www.grandamgt.com/forum/forumdisplay.php?f=22)
-   -   Monsoon Head Unit - no lights, no volume (http://www.grandamgt.com/forum/showthread.php?t=87898)

judge2005 08-14-2012 01:32 PM

Monsoon Head Unit - no lights, no volume
 
I finally got around to replacing the bulbs that light the display on my 2003 Monsoon head unit. Put it all back together and now the unit is completely dark plus the volume knob does nothing. The Steering wheel controls work fine and the radio works and the CD player buttons work and CDs play, just no lights and no head-unit volume control.

I changed the radio/batt fuse (though the existing one looked fine) but it wasn't that.

Before I take it all apart again and get in there with a multi-meter (which I'm not looking forward to as the harness will have to stay attached), can anyone tell me what the problem is or is likely to be? At this stage I'm figuring I must've messed up the harness/connector somehow.

judge2005 08-18-2012 02:53 PM

2 Attachment(s)
It was because a ribbon cable had come out when I took the faceplate off to replace the lightbulbs. The way to replace these bulbs is to flip the head unit over and remove the bottom plate. This is pretty easy. Just prize it out - it hinges at the front. Then you'll have to remove the cassette deck - just unfasten the three screws holding it in and plug the ribbon cable back in. Then put it all back together.

unchained_01 08-18-2012 03:36 PM

glad you got it fixed !!!


All times are GMT -6. The time now is 01:40 PM.

Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2011 GrandAmGT.com