GrandAmGT.com Forum
http://www.pfyc.com GrandAmGT.com Premium Memership Signup
RotorsOnline.com   

Go Back   GrandAmGT.com Forum > GAGT - Technical - Sponsored by www.MilzyMotorSports.com > Technical Q&A

Reply
 
Thread Tools Display Modes
Old 08-13-2017, 11:14 AM   #1
curtpank
GAGT - Member
 
AKA: Curt
Join Date: Jun 2005
Location: Winnipeg Manitoba
Age: 45
Posts: 67
Vehicle: 2002 Grand Am GT Sedan
curtpank Still kinda new, but learning
ckp sensor or coil pack bad with no SES?

hi all - I'm having stalling issues and according to scans it looks like there are crazy fluctuations in engine ignition timing. This causes random stalling while driving once the car has warmed up. It can't be restarted again until it cools down.

I've replaced the ignition switch and lock cylinder and changed plugs, wires, cleaned the MAF sensor too.

The funny thing is there are no CELs lit or stored.

So: is it possible that this is caused by a failing CKP sensor or coil pack? Is that even possible without a CEL?
__________________
"Not Stock and Four Smoking Barrels"

Dr. Speed CAI; WOT-Tech ported UIM and LIM; Billet 65mm Throttle body; S&S headers, downpipe and cat; Borla cat-back; custom PCM tune; front heated seats; altezza clear tails; 18" Core Racing Evo rims; 225/40ZR18 BF Goodrich G-Force KDW2 tires
curtpank is offline   Reply With Quote
Old 08-13-2017, 03:32 PM   #2
young gun
GRAD SCHOOL FUN
 
young gun's Avatar
 
AKA: Erik
Join Date: Apr 2010
Location: Charleston, SC
Age: 24
Posts: 1,567
Vehicle: 00' GAGT
young gun a trusted member
OOOOOOOOOO FINALLY, someone else with my issue. Took me like a month to figure this out. ICM. Sits under the coil packs. Once too hot it starts to mess up and stall you out. But sense you haven't checked your coil packs yet it could be that too.
__________________
2000 - GAGT 14.63@92.9 -Full LX9 with CAI, 65MM TB, 2.5in DP, Borla Cat-Back, Crappy rubber, Magic, Quick tune)
1988 - Dodge Daytona Shelby Z - SOLD!
2008 - Kawasaki Ninja 250r - Slip on exhaust, K&N, Jetted, Sprockets, Lowered and the Girlfriend's now
1984 - Honda Nighthawk 700s - Oldest, quickest and quietess
young gun is offline   Reply With Quote
Old 08-14-2017, 02:43 AM   #3
curtpank
GAGT - Member
 
AKA: Curt
Join Date: Jun 2005
Location: Winnipeg Manitoba
Age: 45
Posts: 67
Vehicle: 2002 Grand Am GT Sedan
curtpank Still kinda new, but learning
okay - I was planning on checking and potentially replacing the ignition coils (there's three of them, I believe). I will test the ICM as well. My thinking is that if only one of the three coils is bad, the car wouldn't stall because there are two other functioning coils (there would be misfires but probably not full-out stalling). If the ICM impacts ignition generally, it may be more likely to cause the stalls.

Does that sound right?
__________________
"Not Stock and Four Smoking Barrels"

Dr. Speed CAI; WOT-Tech ported UIM and LIM; Billet 65mm Throttle body; S&S headers, downpipe and cat; Borla cat-back; custom PCM tune; front heated seats; altezza clear tails; 18" Core Racing Evo rims; 225/40ZR18 BF Goodrich G-Force KDW2 tires
curtpank is offline   Reply With Quote
Old 08-14-2017, 09:07 AM   #4
young gun
GRAD SCHOOL FUN
 
young gun's Avatar
 
AKA: Erik
Join Date: Apr 2010
Location: Charleston, SC
Age: 24
Posts: 1,567
Vehicle: 00' GAGT
young gun a trusted member
Quote:
Originally Posted by curtpank View Post
okay - I was planning on checking and potentially replacing the ignition coils (there's three of them, I believe). I will test the ICM as well. My thinking is that if only one of the three coils is bad, the car wouldn't stall because there are two other functioning coils (there would be misfires but probably not full-out stalling). If the ICM impacts ignition generally, it may be more likely to cause the stalls.

Does that sound right?
Spot on sir. Btw testing the ICM could show negative (IE it works) but with heat generated from the engine it starts to fail, why exactly idk but I tested mine after at autozone and it passed but my car never had that problem again after replacing it.
__________________
2000 - GAGT 14.63@92.9 -Full LX9 with CAI, 65MM TB, 2.5in DP, Borla Cat-Back, Crappy rubber, Magic, Quick tune)
1988 - Dodge Daytona Shelby Z - SOLD!
2008 - Kawasaki Ninja 250r - Slip on exhaust, K&N, Jetted, Sprockets, Lowered and the Girlfriend's now
1984 - Honda Nighthawk 700s - Oldest, quickest and quietess
young gun is offline   Reply With Quote
Old 08-14-2017, 10:17 PM   #5
curtpank
GAGT - Member
 
AKA: Curt
Join Date: Jun 2005
Location: Winnipeg Manitoba
Age: 45
Posts: 67
Vehicle: 2002 Grand Am GT Sedan
curtpank Still kinda new, but learning
well, I changed the ICM this evening but it didn't solve the problem. Same thing: I start the car, let it idle and after about a minute there is a "ping" and it stalls. Then it cannot be restarted again until it cools off (it will start for a second but then backfire and stall immediately). So it's definitely heat-related. It's almost like something is trying to turn on.

So at this point I have changed the ICM, ignition switch, ignition key lock cylinder, spark plugs, wires, alternator and battery.

all I have left is: 1) the coil packs themselves, which looked fine when I took them off to change the ICM, 2) CKP sensor, and 3) the fuel pressure regulator in case it's a fuel thing. I guess tomorrow I'll test the fuel pressure.

Would a bad coil pack make the car stall like this? There are three packs so I figure losing one wouldn't completely stall it....

I just know it's some simple thing but there are still no CELs
__________________
"Not Stock and Four Smoking Barrels"

Dr. Speed CAI; WOT-Tech ported UIM and LIM; Billet 65mm Throttle body; S&S headers, downpipe and cat; Borla cat-back; custom PCM tune; front heated seats; altezza clear tails; 18" Core Racing Evo rims; 225/40ZR18 BF Goodrich G-Force KDW2 tires
curtpank is offline   Reply With Quote
Old Yesterday, 11:41 AM   #6
young gun
GRAD SCHOOL FUN
 
young gun's Avatar
 
AKA: Erik
Join Date: Apr 2010
Location: Charleston, SC
Age: 24
Posts: 1,567
Vehicle: 00' GAGT
young gun a trusted member
Quote:
Originally Posted by curtpank View Post
well, I changed the ICM this evening but it didn't solve the problem. Same thing: I start the car, let it idle and after about a minute there is a "ping" and it stalls. Then it cannot be restarted again until it cools off (it will start for a second but then backfire and stall immediately). So it's definitely heat-related. It's almost like something is trying to turn on.

So at this point I have changed the ICM, ignition switch, ignition key lock cylinder, spark plugs, wires, alternator and battery.

all I have left is: 1) the coil packs themselves, which looked fine when I took them off to change the ICM, 2) CKP sensor, and 3) the fuel pressure regulator in case it's a fuel thing. I guess tomorrow I'll test the fuel pressure.

Would a bad coil pack make the car stall like this? There are three packs so I figure losing one wouldn't completely stall it....

I just know it's some simple thing but there are still no CELs
GDI. Fuel pressure sounds like a good thing to check. I wouldn't think one coil pack would make it stall that way. I don't know symptoms of a bad CKP sensor but the more I think about it the more I think I did change mine while trying to figure this out but obviously for me it wasn't that.
__________________
2000 - GAGT 14.63@92.9 -Full LX9 with CAI, 65MM TB, 2.5in DP, Borla Cat-Back, Crappy rubber, Magic, Quick tune)
1988 - Dodge Daytona Shelby Z - SOLD!
2008 - Kawasaki Ninja 250r - Slip on exhaust, K&N, Jetted, Sprockets, Lowered and the Girlfriend's now
1984 - Honda Nighthawk 700s - Oldest, quickest and quietess
young gun is offline   Reply With Quote
Old Yesterday, 11:18 PM   #7
curtpank
GAGT - Member
 
AKA: Curt
Join Date: Jun 2005
Location: Winnipeg Manitoba
Age: 45
Posts: 67
Vehicle: 2002 Grand Am GT Sedan
curtpank Still kinda new, but learning
I think I've done almost everything that could go with spark or electricity. So I suppose I'll start with the fuel side now. I'm going to check fuel pressure.

the problem has worsened - first it was a stall every few weeks. Then it got more and more frequent. Eventually it was every day, then it would stall after a minute or so and now it stalls within a few seconds of starting.
__________________
"Not Stock and Four Smoking Barrels"

Dr. Speed CAI; WOT-Tech ported UIM and LIM; Billet 65mm Throttle body; S&S headers, downpipe and cat; Borla cat-back; custom PCM tune; front heated seats; altezza clear tails; 18" Core Racing Evo rims; 225/40ZR18 BF Goodrich G-Force KDW2 tires
curtpank is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -6. The time now is 06:59 AM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2011 GrandAmGT.com
RotorsOnline.com