GrandAmGT.com Forum
http://www.pfyc.com GrandAmGT.com Premium Memership Signup
CustomCarGrills.com   

Go Back   GrandAmGT.com Forum > GAGT - Technical - Sponsored by www.MilzyMotorSports.com > Technical Q&A

Reply
 
Thread Tools Display Modes
Old 09-21-2009, 05:13 PM   #1
GA2000GTSpeed
GAGT - Member
 
GA2000GTSpeed's Avatar
 
AKA: Josh
Join Date: Jan 2008
Location: Freeman Missouri
Age: 27
Posts: 411
Vehicle: 00 GAGT, 79 Jag XJ6
GA2000GTSpeed Gettin' there
Hydrolock...

Well i got another f up... its been raining all day down here in pitt and it picked up and kinda flash flooded and i just got my car into my garage... and the engine is locked.... im going to see if i can fix it by taking off the heads and getting it all dried out... and one hell of a long night...

Any suggestions or anyone that has had this problem and fixed it this way?
__________________
Current mods: RSM Supercharger kit, S&S Headers, Upgraded Clutches, Borla cat-back, Drilled and Slotted Camaro rotors and Calipers, MSD coil packs, EGR Block Off, 180 thermo, MSD wires, Tuned Myself with DHP, 2 12 inch Alpine type R's, Kenwood bass booster 1700 watt Amp, Red Dual flip down head unit, Tinted Tails, Custom Painted Black With Red Interior, Double pod A pillar, A/F Gauge, Vac/Boost Gauge.
Future Mods: Heads, P&P Intake manifolds, 65mm TB, HP Tuners, .
GA2000GTSpeed is offline   Reply With Quote
Old 09-21-2009, 05:43 PM   #2
GrandAmMe
It's Personal...
 
GrandAmMe's Avatar
 
AKA: Adam
Join Date: Nov 2008
Location: Ajax, ON
Age: 22
Posts: 1,005
Vehicle: 2006 Saab 93 Aero
GrandAmMe Gettin' there
Send a message via MSN to GrandAmMe
That suck majorly...... did u pull the plugs before you pulled the heads to get some water out that way?
__________________
'06 Saab 93 Aero 2.8T 'Combi 6MT
GrandAmMe is offline   Reply With Quote
Old 09-21-2009, 05:47 PM   #3
GA2000GTSpeed
GAGT - Member
 
GA2000GTSpeed's Avatar
 
AKA: Josh
Join Date: Jan 2008
Location: Freeman Missouri
Age: 27
Posts: 411
Vehicle: 00 GAGT, 79 Jag XJ6
GA2000GTSpeed Gettin' there
no im just now starting...
__________________
Current mods: RSM Supercharger kit, S&S Headers, Upgraded Clutches, Borla cat-back, Drilled and Slotted Camaro rotors and Calipers, MSD coil packs, EGR Block Off, 180 thermo, MSD wires, Tuned Myself with DHP, 2 12 inch Alpine type R's, Kenwood bass booster 1700 watt Amp, Red Dual flip down head unit, Tinted Tails, Custom Painted Black With Red Interior, Double pod A pillar, A/F Gauge, Vac/Boost Gauge.
Future Mods: Heads, P&P Intake manifolds, 65mm TB, HP Tuners, .
GA2000GTSpeed is offline   Reply With Quote
Old 09-21-2009, 06:06 PM   #4
GrandAmMe
It's Personal...
 
GrandAmMe's Avatar
 
AKA: Adam
Join Date: Nov 2008
Location: Ajax, ON
Age: 22
Posts: 1,005
Vehicle: 2006 Saab 93 Aero
GrandAmMe Gettin' there
Send a message via MSN to GrandAmMe
ok well what i would do is just pull all front 3 plugs and check and see which ones are wet and which ones are dry....You may of got lucky and only got a few in the front locked but pull the back ones if necessary. Instead of having to rip apart the motor just pull the plugs....take apart the air intake assembly...change oil 2 times if the water was that bad etc....
__________________
'06 Saab 93 Aero 2.8T 'Combi 6MT
GrandAmMe is offline   Reply With Quote
Old 09-21-2009, 06:09 PM   #5
GA2000GTSpeed
GAGT - Member
 
GA2000GTSpeed's Avatar
 
AKA: Josh
Join Date: Jan 2008
Location: Freeman Missouri
Age: 27
Posts: 411
Vehicle: 00 GAGT, 79 Jag XJ6
GA2000GTSpeed Gettin' there
yah 5 outta the 6 r wet and drained the oil... ater came out first then the oil... gonna try using the lucas oil flush... or what ever its called new plugs. i used the starter to crank it to push out as much water as i could through the spark plug holes before draining the oil
__________________
Current mods: RSM Supercharger kit, S&S Headers, Upgraded Clutches, Borla cat-back, Drilled and Slotted Camaro rotors and Calipers, MSD coil packs, EGR Block Off, 180 thermo, MSD wires, Tuned Myself with DHP, 2 12 inch Alpine type R's, Kenwood bass booster 1700 watt Amp, Red Dual flip down head unit, Tinted Tails, Custom Painted Black With Red Interior, Double pod A pillar, A/F Gauge, Vac/Boost Gauge.
Future Mods: Heads, P&P Intake manifolds, 65mm TB, HP Tuners, .
GA2000GTSpeed is offline   Reply With Quote
Old 09-21-2009, 06:19 PM   #6
GrandAmMe
It's Personal...
 
GrandAmMe's Avatar
 
AKA: Adam
Join Date: Nov 2008
Location: Ajax, ON
Age: 22
Posts: 1,005
Vehicle: 2006 Saab 93 Aero
GrandAmMe Gettin' there
Send a message via MSN to GrandAmMe
ok well if u think u got a good amount if not all the water out using the spark plug methop then you might be fine!
__________________
'06 Saab 93 Aero 2.8T 'Combi 6MT
GrandAmMe is offline   Reply With Quote
Old 09-21-2009, 06:28 PM   #7
lone_wolf025
Spirit guides
 
lone_wolf025's Avatar
 
AKA: Jon
Join Date: Mar 2006
Location: Chicago, IL
Age: 34
Posts: 3,139
Vehicle: 2003 Grand Am GT1
lone_wolf025 Gettin' there
Send a message via AIM to lone_wolf025
Quote:
Originally Posted by GrandAmMe View Post
ok well if u think u got a good amount if not all the water out using the spark plug methop then you might be fine!
Hopefully. This didn't happen while you were driving did it? I don't think the starter has enough power to bend a piston rod so provided you didn't run it and then have it stop you should be good. Also, double check all your sensors and wiring and make sure they're dried out. Battery should be disconnected if its not already until its dried up.
__________________
A lack of something better

Never ask why people do strange/stupid things...the answer just makes it worse...

14.841 @91.56mph


Quote:
Originally Posted by Someone else
Ahhh but that would be in the land of "Makes Sense"...you forget that we live in the land of "DUHHH"
lone_wolf025 is offline   Reply With Quote
Old 09-21-2009, 06:30 PM   #8
XtremeGaGt00
converted to ls1 :)
 
XtremeGaGt00's Avatar
 
AKA: Jason
Join Date: Nov 2003
Location: romeoville, il
Age: 32
Posts: 916
Vehicle: 00gagt 99gtp 99t/a
XtremeGaGt00 Gettin' there
Send a message via AIM to XtremeGaGt00
this happened to me also, my engine gulped in a good amout of water..i took the plugs out, cranked the motor..water came out like a geiser..i let it sit all night with a fan blowing into the t.b. with the linkage w.o.t. fired up the next day..
__________________
00 GaGt turbo/camm'd SOLD!13.68 @100.34.. 2.0 60' w/ slipping trans...stock cam/stock 103xxx bottom end
99 GTP demodded! 12.8 @107.19.. 1.7 60' on 555r's
99 Trans Am6.0 lq4,studded,t76 turbo, turbo cam, 3.5in exhaust,#80's,dual walbros,ford 9in rear, adj, tq arm, adj, control arms,160 stat,ls6 intake,555r's 11.8 @122.<<--nitrous only times
XtremeGaGt00 is offline   Reply With Quote
Old 09-21-2009, 06:40 PM   #9
GA2000GTSpeed
GAGT - Member
 
GA2000GTSpeed's Avatar
 
AKA: Josh
Join Date: Jan 2008
Location: Freeman Missouri
Age: 27
Posts: 411
Vehicle: 00 GAGT, 79 Jag XJ6
GA2000GTSpeed Gettin' there
ok im gonna have to take off the uim to make sure all the water is out of the manifolds... dried the plugs and have been flushing the oil with seafoam and lucas oil addative...
__________________
Current mods: RSM Supercharger kit, S&S Headers, Upgraded Clutches, Borla cat-back, Drilled and Slotted Camaro rotors and Calipers, MSD coil packs, EGR Block Off, 180 thermo, MSD wires, Tuned Myself with DHP, 2 12 inch Alpine type R's, Kenwood bass booster 1700 watt Amp, Red Dual flip down head unit, Tinted Tails, Custom Painted Black With Red Interior, Double pod A pillar, A/F Gauge, Vac/Boost Gauge.
Future Mods: Heads, P&P Intake manifolds, 65mm TB, HP Tuners, .
GA2000GTSpeed is offline   Reply With Quote
Old 09-21-2009, 06:41 PM   #10
GA2000GTSpeed
GAGT - Member
 
GA2000GTSpeed's Avatar
 
AKA: Josh
Join Date: Jan 2008
Location: Freeman Missouri
Age: 27
Posts: 411
Vehicle: 00 GAGT, 79 Jag XJ6
GA2000GTSpeed Gettin' there
oh and my battery is in the trunk so thats all good
__________________
Current mods: RSM Supercharger kit, S&S Headers, Upgraded Clutches, Borla cat-back, Drilled and Slotted Camaro rotors and Calipers, MSD coil packs, EGR Block Off, 180 thermo, MSD wires, Tuned Myself with DHP, 2 12 inch Alpine type R's, Kenwood bass booster 1700 watt Amp, Red Dual flip down head unit, Tinted Tails, Custom Painted Black With Red Interior, Double pod A pillar, A/F Gauge, Vac/Boost Gauge.
Future Mods: Heads, P&P Intake manifolds, 65mm TB, HP Tuners, .
GA2000GTSpeed is offline   Reply With Quote
Old 09-21-2009, 06:44 PM   #11
lone_wolf025
Spirit guides
 
lone_wolf025's Avatar
 
AKA: Jon
Join Date: Mar 2006
Location: Chicago, IL
Age: 34
Posts: 3,139
Vehicle: 2003 Grand Am GT1
lone_wolf025 Gettin' there
Send a message via AIM to lone_wolf025
Quote:
Originally Posted by GA2000GTSpeed View Post
oh and my battery is in the trunk so thats all good
My thought is that you should just disconnect it (provided you don't have a big fuse inline with the wires off the battery) so that if something is still wet you won't short it out. Chances are its fine, but better safe than sorry.

Oh and don't over flush the engine with cleaners. When you get the car running again you'll want to have a coating of oil on the parts just so that the initial wear is at a minimum so just keep that in mind.
__________________
A lack of something better

Never ask why people do strange/stupid things...the answer just makes it worse...

14.841 @91.56mph


Quote:
Originally Posted by Someone else
Ahhh but that would be in the land of "Makes Sense"...you forget that we live in the land of "DUHHH"
lone_wolf025 is offline   Reply With Quote
Old 09-21-2009, 07:14 PM   #12
PhantomLover007
'Til I see you again
 
PhantomLover007's Avatar
 
AKA: Matt
Join Date: Oct 2006
Location: Augusta/ Ft Gordon, GA
Age: 45
Posts: 7,676
Vehicle: 02 SC/T kitted & M62'd
PhantomLover007 has made plenty of valid pointsPhantomLover007 has made plenty of valid points
Send a message via AIM to PhantomLover007 Send a message via Yahoo to PhantomLover007
Damn. Some messed up sh1t. I hope ya get the GA running again.
__________________
Quote:
Originally Posted by Ajaxus View Post
Oh, and I'm now house trained, so no more urinary issues to worry about.

My ride:
GA's ONLY SC/T'ed Grand Am according to CarDomain
PhantomLover007 is offline   Reply With Quote
Old 09-21-2009, 07:32 PM   #13
GrandAmMe
It's Personal...
 
GrandAmMe's Avatar
 
AKA: Adam
Join Date: Nov 2008
Location: Ajax, ON
Age: 22
Posts: 1,005
Vehicle: 2006 Saab 93 Aero
GrandAmMe Gettin' there
Send a message via MSN to GrandAmMe
I hope that it wasnt running at full operating temp cause you could of cracked a piston
__________________
'06 Saab 93 Aero 2.8T 'Combi 6MT
GrandAmMe is offline   Reply With Quote
Old 09-21-2009, 07:37 PM   #14
GA2000GTSpeed
GAGT - Member
 
GA2000GTSpeed's Avatar
 
AKA: Josh
Join Date: Jan 2008
Location: Freeman Missouri
Age: 27
Posts: 411
Vehicle: 00 GAGT, 79 Jag XJ6
GA2000GTSpeed Gettin' there
no it wasent. but it was running when i hit the water. and ya thats why i used the lucas after the seafoam
__________________
Current mods: RSM Supercharger kit, S&S Headers, Upgraded Clutches, Borla cat-back, Drilled and Slotted Camaro rotors and Calipers, MSD coil packs, EGR Block Off, 180 thermo, MSD wires, Tuned Myself with DHP, 2 12 inch Alpine type R's, Kenwood bass booster 1700 watt Amp, Red Dual flip down head unit, Tinted Tails, Custom Painted Black With Red Interior, Double pod A pillar, A/F Gauge, Vac/Boost Gauge.
Future Mods: Heads, P&P Intake manifolds, 65mm TB, HP Tuners, .
GA2000GTSpeed is offline   Reply With Quote
Old 09-21-2009, 07:42 PM   #15
lone_wolf025
Spirit guides
 
lone_wolf025's Avatar
 
AKA: Jon
Join Date: Mar 2006
Location: Chicago, IL
Age: 34
Posts: 3,139
Vehicle: 2003 Grand Am GT1
lone_wolf025 Gettin' there
Send a message via AIM to lone_wolf025
Quote:
Originally Posted by GA2000GTSpeed View Post
no it wasent. but it was running when i hit the water. and ya thats why i used the lucas after the seafoam
It was running when you hit the water? Uhh...well hopefully nothing major was damaged. Guess you'll have to wait and see once everything is dried out.
__________________
A lack of something better

Never ask why people do strange/stupid things...the answer just makes it worse...

14.841 @91.56mph


Quote:
Originally Posted by Someone else
Ahhh but that would be in the land of "Makes Sense"...you forget that we live in the land of "DUHHH"
lone_wolf025 is offline   Reply With Quote
Old 09-21-2009, 08:31 PM   #16
GA2000GTSpeed
GAGT - Member
 
GA2000GTSpeed's Avatar
 
AKA: Josh
Join Date: Jan 2008
Location: Freeman Missouri
Age: 27
Posts: 411
Vehicle: 00 GAGT, 79 Jag XJ6
GA2000GTSpeed Gettin' there
well it took awhile but she started up for me... i only ran her for a lil cause im drying out my filter and my tubing is just pointing up for now just so i could get her going... but shes alive and i prolly wont know how she runes till morn
__________________
Current mods: RSM Supercharger kit, S&S Headers, Upgraded Clutches, Borla cat-back, Drilled and Slotted Camaro rotors and Calipers, MSD coil packs, EGR Block Off, 180 thermo, MSD wires, Tuned Myself with DHP, 2 12 inch Alpine type R's, Kenwood bass booster 1700 watt Amp, Red Dual flip down head unit, Tinted Tails, Custom Painted Black With Red Interior, Double pod A pillar, A/F Gauge, Vac/Boost Gauge.
Future Mods: Heads, P&P Intake manifolds, 65mm TB, HP Tuners, .
GA2000GTSpeed is offline   Reply With Quote
Old 09-21-2009, 09:01 PM   #17
GrandAmMe
It's Personal...
 
GrandAmMe's Avatar
 
AKA: Adam
Join Date: Nov 2008
Location: Ajax, ON
Age: 22
Posts: 1,005
Vehicle: 2006 Saab 93 Aero
GrandAmMe Gettin' there
Send a message via MSN to GrandAmMe
Good to hear and if i were you i wouldnt re use the filter...just get a new one.
__________________
'06 Saab 93 Aero 2.8T 'Combi 6MT
GrandAmMe is offline   Reply With Quote
Old 09-21-2009, 09:51 PM   #18
Lamech
GAGT - Member
 
Lamech's Avatar
 
AKA: Barry
Join Date: Sep 2009
Location: NLR, AR
Posts: 121
Vehicle: 2001 Grand Am GT
Lamech Gettin' there
I hope everything works out well for you tomorrow, knew a guy with a GTO that got some similar bad luck. Just a quick bit about your avatar and this is no lie.

A year ago and friend and I got pulled over by a cop doing only 5 over. First time I was ever pulled over so I was nervous as hell. Cop comes to the window and asks me what my excuse was for going over the stated speed limit.

Before I could answer with something serious, my friend blurts out "WE WERE IN A HURRY TO GET THESE DELICIOUS DONUTS TO YOU!!!" Luckily for me he was in a good mood and we all got a good laugh out of it and I got away with a warning.

Never have I been pulled over for 5 over but o well, just make sure you have fresh pastries with you at all times!
Lamech is offline   Reply With Quote
Old 09-22-2009, 12:22 AM   #19
GA2000GTSpeed
GAGT - Member
 
GA2000GTSpeed's Avatar
 
AKA: Josh
Join Date: Jan 2008
Location: Freeman Missouri
Age: 27
Posts: 411
Vehicle: 00 GAGT, 79 Jag XJ6
GA2000GTSpeed Gettin' there
well i got the filter dried out good with a fan and i have been driving my ga for the past half hour she runs fine now that i fixed my vacuum leaks...

Lol nice one ill remember that
__________________
Current mods: RSM Supercharger kit, S&S Headers, Upgraded Clutches, Borla cat-back, Drilled and Slotted Camaro rotors and Calipers, MSD coil packs, EGR Block Off, 180 thermo, MSD wires, Tuned Myself with DHP, 2 12 inch Alpine type R's, Kenwood bass booster 1700 watt Amp, Red Dual flip down head unit, Tinted Tails, Custom Painted Black With Red Interior, Double pod A pillar, A/F Gauge, Vac/Boost Gauge.
Future Mods: Heads, P&P Intake manifolds, 65mm TB, HP Tuners, .
GA2000GTSpeed is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -6. The time now is 02:25 AM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2011 GrandAmGT.com
CustomCarGrills.com